summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-18 16:22:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-18 16:22:49 +0000
commit0074d117ebef57b7f0464efa5d6e8008bcc9b931 (patch)
tree6755fe485c9da62d38d8ffa6390e767cbbbd2cb8 /dev-ml
parentFix building against xorg-server-1.12. (diff)
downloadgentoo-2-0074d117ebef57b7f0464efa5d6e8008bcc9b931.tar.gz
gentoo-2-0074d117ebef57b7f0464efa5d6e8008bcc9b931.tar.bz2
gentoo-2-0074d117ebef57b7f0464efa5d6e8008bcc9b931.zip
version bump
(Portage version: 2.2.0_alpha91/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/react/ChangeLog9
-rw-r--r--dev-ml/react/react-0.9.3.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-ml/react/ChangeLog b/dev-ml/react/ChangeLog
index 71a3662a4ff6..53637d2d4f2c 100644
--- a/dev-ml/react/ChangeLog
+++ b/dev-ml/react/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/react
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/react/ChangeLog,v 1.5 2010/06/20 12:34:04 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/react/ChangeLog,v 1.6 2012/03/18 16:22:49 aballier Exp $
+
+*react-0.9.3 (18 Mar 2012)
+
+ 18 Mar 2012; Alexis Ballier <aballier@gentoo.org> +react-0.9.3.ebuild:
+ version bump
20 Jun 2010; Alexis Ballier <aballier@gentoo.org> -react-0.9.0.ebuild,
-react-0.9.1.ebuild:
diff --git a/dev-ml/react/react-0.9.3.ebuild b/dev-ml/react/react-0.9.3.ebuild
new file mode 100644
index 000000000000..e760941c0741
--- /dev/null
+++ b/dev-ml/react/react-0.9.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/react/react-0.9.3.ebuild,v 1.1 2012/03/18 16:22:49 aballier Exp $
+
+EAPI="4"
+
+inherit multilib findlib
+
+DESCRIPTION="OCaml module for functional reactive programming"
+HOMEPAGE="http://erratique.ch/software/react"
+SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+ocamlopt debug test"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ocaml setup.ml -configure \
+ --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ $(use_enable test tests) \
+ || die
+}
+
+src_compile() {
+ ocaml setup.ml -build || die
+}
+
+src_test() {
+ ocaml setup.ml -test || die
+}
+
+src_install() {
+ findlib_src_preinst
+ ocaml setup.ml -install || die
+ dodoc CHANGES README
+}