summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-02-23 21:26:25 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-02-23 21:26:25 +0000
commit24643e50540aa7674d47bf6bbc9c2675f73cfa5c (patch)
tree4b7865e66960205f22b8bf03af4034248374ce68 /dev-ml
parentfix tabbing (diff)
downloadgentoo-2-24643e50540aa7674d47bf6bbc9c2675f73cfa5c.tar.gz
gentoo-2-24643e50540aa7674d47bf6bbc9c2675f73cfa5c.tar.bz2
gentoo-2-24643e50540aa7674d47bf6bbc9c2675f73cfa5c.zip
new version, for which source is actually awailable at the moment..
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog12
-rw-r--r--dev-ml/pcre-ocaml/files/digest-pcre-ocaml-4.33.01
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-4.33.0.ebuild35
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 48982c311503..bd8f373b7f73 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,8 +1,16 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.2 2003/02/12 06:12:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.3 2003/02/23 21:26:25 george Exp $
-*pcre-ocaml-4.26.3.ebuild (28 Jun 2002)
+*pcre-ocaml-4.33.0 (23 Feb 2003)
+
+ 23 Feb 2003; George Shapovalov <george@gentoo.org> pcre-ocaml-4.33.0.ebuild :
+
+ new version (#12318)
+ as author has a habit of removing old versions from his homepage, this one is mirrored
+ ebuild submitted by Bardur Arantsson <bardur-gta@odense.kollegienet.dk>
+
+*pcre-ocaml-4.26.3 (28 Jun 2002)
28 Jun 2002; G Shapovalov <george@gentoo.org> all :
diff --git a/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-4.33.0 b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-4.33.0
new file mode 100644
index 000000000000..d18392aab5d5
--- /dev/null
+++ b/dev-ml/pcre-ocaml/files/digest-pcre-ocaml-4.33.0
@@ -0,0 +1 @@
+MD5 2cfa3e99c3467cc69790adcb342d6ccb pcre-ocaml-4.33.0.tar.bz2 39575
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-4.33.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-4.33.0.ebuild
new file mode 100644
index 000000000000..6d4dbfa78277
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-4.33.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-4.33.0.ebuild,v 1.1 2003/02/23 21:26:25 george Exp $
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.04-r1
+ >=dev-libs/libpcre-3.9-r1
+ >=dev-ml/findlib-0.8"
+
+SRC_URI="http://www.oefai.at/~markus/ocaml_sources/${P}.tar.bz2"
+S=${WORKDIR}/${P}
+
+SLOT="3"
+KEYWORDS="x86"
+IUSE=""
+
+src_compile() {
+ emake all || die
+}
+
+src_install () {
+ # which directory does the lib go into?
+ destdir=`ocamlfind printconf destdir`
+
+ # install
+ mkdir -p ${D}${destdir} || die
+ make OCAMLFIND_DESTDIR=${D}${destdir} \
+ OCAMLFIND_LDCONF=dummy install || die
+
+ # install documentation
+ dodoc LICENSE README VERSION
+}