summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-10 12:16:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-10 12:16:04 +0000
commit573f2aca71be0efe3934bcc26fe55a6ce5d87c4d (patch)
tree723224c2e93e6927e01a997822e282004e8d0a70 /dev-ml
parentQA: add missing RDEPEND and 'die' statements (diff)
downloadgentoo-2-573f2aca71be0efe3934bcc26fe55a6ce5d87c4d.tar.gz
gentoo-2-573f2aca71be0efe3934bcc26fe55a6ce5d87c4d.tar.bz2
gentoo-2-573f2aca71be0efe3934bcc26fe55a6ce5d87c4d.zip
fix build with ocaml-4
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/fort/ChangeLog8
-rw-r--r--dev-ml/fort/files/fort-0.4.2-ocaml4.patch22
-rw-r--r--dev-ml/fort/fort-0.4.2.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-ml/fort/ChangeLog b/dev-ml/fort/ChangeLog
index 797dae03f05f..07d89d790d81 100644
--- a/dev-ml/fort/ChangeLog
+++ b/dev-ml/fort/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/fort
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/fort/ChangeLog,v 1.4 2011/02/12 16:01:46 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/fort/ChangeLog,v 1.5 2012/10/10 12:16:04 aballier Exp $
+
+ 10 Oct 2012; Alexis Ballier <aballier@gentoo.org> fort-0.4.2.ebuild,
+ +files/fort-0.4.2-ocaml4.patch:
+ fix build with ocaml-4
12 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org> fort-0.4.2.ebuild:
Marked ~ppc wrt #322673
diff --git a/dev-ml/fort/files/fort-0.4.2-ocaml4.patch b/dev-ml/fort/files/fort-0.4.2-ocaml4.patch
new file mode 100644
index 000000000000..1c688a995446
--- /dev/null
+++ b/dev-ml/fort/files/fort-0.4.2-ocaml4.patch
@@ -0,0 +1,22 @@
+Index: fort-0.4.2/Makefile
+===================================================================
+--- fort-0.4.2.orig/Makefile
++++ fort-0.4.2/Makefile
+@@ -3,7 +3,7 @@
+
+ include Makefile.config
+
+-OCAMLC := ocamlc
++OCAMLC := ocamlc -I +compiler-libs
+
+ # FORT top-level interpreter
+ NAME := fort
+@@ -16,7 +16,7 @@ LIBS := unix
+ EXECUTABLE := $(NAME)$(EXEC_SUFFIX)
+
+ $(EXECUTABLE): $(OBJECTS)
+- $(OCAMLC) -linkall -o $@ toplevellib.cma $(LIBS:%=%.cma) $(OBJECTS)
++ $(OCAMLC) -linkall -o $@ ocamlcommon.cma ocamlbytecomp.cma ocamltoplevel.cma $(LIBS:%=%.cma) $(OBJECTS)
+
+ install: $(EXECUTABLE) $(OBJECTS)
+ mkdir -p $(DESTDIR)$(LIBDIR)
diff --git a/dev-ml/fort/fort-0.4.2.ebuild b/dev-ml/fort/fort-0.4.2.ebuild
index d826304b42f6..220575f441b1 100644
--- a/dev-ml/fort/fort-0.4.2.ebuild
+++ b/dev-ml/fort/fort-0.4.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/fort/fort-0.4.2.ebuild,v 1.4 2011/02/12 16:01:46 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/fort/fort-0.4.2.ebuild,v 1.5 2012/10/10 12:16:04 aballier Exp $
EAPI=2
-inherit multilib
+inherit multilib eutils
DESCRIPTION="provides an environment for testing programs and Objective Caml modules"
HOMEPAGE="http://fort.sourceforge.net/"
@@ -19,6 +19,7 @@ DEPEND="dev-lang/ocaml"
RDEPEND="${DEPEND}"
src_prepare() {
+ has_version '>=dev-lang/ocaml-4' && epatch "${FILESDIR}/${P}-ocaml4.patch"
sed -i -e "s:\$(BINDIR):\$(DESTDIR)&:"\
-e "s:\$(LIBDIR):\$(DESTDIR)&:" Makefile || die
}