summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-29 23:25:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-29 23:25:29 +0000
commit7a2fafd139bb0c36caee055f10b393b84fe81b75 (patch)
tree5ea6ec4e443eb14b7017eda4757e22f2f901f6a5 /dev-ml
parentversion bump (diff)
downloadgentoo-2-7a2fafd139bb0c36caee055f10b393b84fe81b75.tar.gz
gentoo-2-7a2fafd139bb0c36caee055f10b393b84fe81b75.tar.bz2
gentoo-2-7a2fafd139bb0c36caee055f10b393b84fe81b75.zip
version bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/bolt/ChangeLog7
-rw-r--r--dev-ml/bolt/bolt-1.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ml/bolt/ChangeLog b/dev-ml/bolt/ChangeLog
index 088b295bfb32..9c919d086539 100644
--- a/dev-ml/bolt/ChangeLog
+++ b/dev-ml/bolt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/bolt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bolt/ChangeLog,v 1.2 2012/08/22 14:19:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bolt/ChangeLog,v 1.3 2012/10/29 23:25:29 aballier Exp $
+
+*bolt-1.4 (29 Oct 2012)
+
+ 29 Oct 2012; Alexis Ballier <aballier@gentoo.org> +bolt-1.4.ebuild:
+ version bump
*bolt-1.3 (22 Aug 2012)
diff --git a/dev-ml/bolt/bolt-1.4.ebuild b/dev-ml/bolt/bolt-1.4.ebuild
new file mode 100644
index 000000000000..404718f0f682
--- /dev/null
+++ b/dev-ml/bolt/bolt-1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bolt/bolt-1.4.ebuild,v 1.1 2012/10/29 23:25:29 aballier Exp $
+
+EAPI=4
+
+inherit findlib
+
+DESCRIPTION="Logging tool for the Objective Caml language"
+HOMEPAGE="http://bolt.x9c.fr/"
+SRC_URI="http://bolt.x9c.fr/distrib/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ sh configure
+}
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES FEATURES
+ use doc && dohtml ocamldoc/*
+}