summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-09-21 19:10:34 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-09-21 19:10:34 +0000
commitc1c1e20d01c661b1fe30ca8ef6b9373715462077 (patch)
treece8922c5cfe783aa1f2eafeaf863b8d8ee3aee17 /dev-ml
parentKeyworded ~sparc (diff)
downloadgentoo-2-c1c1e20d01c661b1fe30ca8ef6b9373715462077.tar.gz
gentoo-2-c1c1e20d01c661b1fe30ca8ef6b9373715462077.tar.bz2
gentoo-2-c1c1e20d01c661b1fe30ca8ef6b9373715462077.zip
New ebuild for an OCaml graph library.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlgraph/ChangeLog11
-rw-r--r--dev-ml/ocamlgraph/Manifest3
-rw-r--r--dev-ml/ocamlgraph/files/digest-ocamlgraph-0.811
-rw-r--r--dev-ml/ocamlgraph/metadata.xml5
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild36
5 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/ChangeLog b/dev-ml/ocamlgraph/ChangeLog
new file mode 100644
index 000000000000..8855eebfcd9e
--- /dev/null
+++ b/dev-ml/ocamlgraph/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocamlgraph
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.1 2005/09/21 19:10:34 mattam Exp $
+
+*ocamlgraph-0.81 (21 Sep 2005)
+
+ 21 Sep 2005; Matthieu Sozeau <mattam@gentoo.org> +metadata.xml,
+ +ocamlgraph-0.81.ebuild:
+ ocamlgraph is a graph library for OCaml which implements a wide variety of
+ graphs and algorithms.
+
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
new file mode 100644
index 000000000000..ee364e9f4cfc
--- /dev/null
+++ b/dev-ml/ocamlgraph/Manifest
@@ -0,0 +1,3 @@
+MD5 ea874778623ba1ac66b88da310b026a0 ocamlgraph-0.81.ebuild 774
+MD5 648a541494aceee26dbcfd76164f37ea metadata.xml 157
+MD5 ba513d22f4e8a7de7b3ab289a6a668fc files/digest-ocamlgraph-0.81 66
diff --git a/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.81 b/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.81
new file mode 100644
index 000000000000..fdc0b11ea639
--- /dev/null
+++ b/dev-ml/ocamlgraph/files/digest-ocamlgraph-0.81
@@ -0,0 +1 @@
+MD5 c9592cd99502fd84cee90ca336701635 ocamlgraph-0.81.tar.gz 97467
diff --git a/dev-ml/ocamlgraph/metadata.xml b/dev-ml/ocamlgraph/metadata.xml
new file mode 100644
index 000000000000..849ed8ebf13d
--- /dev/null
+++ b/dev-ml/ocamlgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild b/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild
new file mode 100644
index 000000000000..6b8783a0ae62
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-0.81.ebuild,v 1.1 2005/09/21 19:10:34 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlgraph/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlgraph/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+DEPEND=">=dev-lang/ocaml-3.08
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ if use doc;
+ then
+ emake doc
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ make install-findlib || die
+
+ dodoc README COPYING CREDITS FAQ CHANGES
+ if use doc;
+ then
+ dohtml doc/*
+ fi
+}