summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-01-16 15:30:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-01-16 15:30:34 +0000
commitc282fb1863c9dfb1a67a5e83fd656dc3b394d75d (patch)
treed2d5d3b0c8cdb46bbedb3aca1ae81c23e854caa4 /dev-ml
parentversion bump (diff)
downloadgentoo-2-c282fb1863c9dfb1a67a5e83fd656dc3b394d75d.tar.gz
gentoo-2-c282fb1863c9dfb1a67a5e83fd656dc3b394d75d.tar.bz2
gentoo-2-c282fb1863c9dfb1a67a5e83fd656dc3b394d75d.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog9
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-6.2.5.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 9dd88316483f..fb3d13584700 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.41 2011/12/31 11:30:27 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.42 2012/01/16 15:30:34 aballier Exp $
+
+*pcre-ocaml-6.2.5 (16 Jan 2012)
+
+ 16 Jan 2012; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-6.2.5.ebuild:
+ version bump
*pcre-ocaml-6.2.4 (31 Dec 2011)
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-6.2.5.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.5.ebuild
new file mode 100644
index 000000000000..448541267717
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-6.2.5.ebuild,v 1.1 2012/01/16 15:30:34 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-linkopts.patch"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}