summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-03-15 20:04:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-03-15 20:04:27 +0000
commitce1cb4c5b1e7d6bfea835b98fcd560ea204c0526 (patch)
treee842d5013732e3148bd15820180861433bab06e2 /dev-ml
parentVersion bump to fix bug #358943. Thanks to Oliver Nautsch <oliver.nautsch@gma... (diff)
downloadgentoo-2-ce1cb4c5b1e7d6bfea835b98fcd560ea204c0526.tar.gz
gentoo-2-ce1cb4c5b1e7d6bfea835b98fcd560ea204c0526.tar.bz2
gentoo-2-ce1cb4c5b1e7d6bfea835b98fcd560ea204c0526.zip
Initial import, ebuild by Vladimir Ivanov, bug #355755, with modifications and simplifications by me
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-fileutils/ChangeLog11
-rw-r--r--dev-ml/ocaml-fileutils/metadata.xml9
-rw-r--r--dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild31
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/ocaml-fileutils/ChangeLog b/dev-ml/ocaml-fileutils/ChangeLog
new file mode 100644
index 000000000000..d85cbde5e253
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocaml-fileutils
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-fileutils/ChangeLog,v 1.1 2011/03/15 20:04:27 aballier Exp $
+
+*ocaml-fileutils-0.4.2 (15 Mar 2011)
+
+ 15 Mar 2011; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-fileutils-0.4.2.ebuild, +metadata.xml:
+ Initial import, ebuild by Vladimir Ivanov, bug #355755, with modifications
+ and simplifications by me
+
diff --git a/dev-ml/ocaml-fileutils/metadata.xml b/dev-ml/ocaml-fileutils/metadata.xml
new file mode 100644
index 000000000000..f6b3ee22be88
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+<maintainer>
+ <email>v.ivanov@ymail.com</email>
+ <name>Vladimir Ivanov</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild
new file mode 100644
index 000000000000..2a44549a5ecf
--- /dev/null
+++ b/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-fileutils/ocaml-fileutils-0.4.2.ebuild,v 1.1 2011/03/15 20:04:27 aballier Exp $
+
+EAPI=3
+
+inherit findlib
+
+DESCRIPTION="Pure OCaml functions to manipulate real file (POSIX like) and filename"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-fileutils"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/462/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-ml/findlib"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_prepare() {
+ use ocamlopt || sed -i -e 's/OCAMLBEST=.*/OCAMLBEST=byte/' configure
+}
+
+src_install() {
+ findlib_src_preinst
+ emake htmldir="${ED}/usr/share/doc/${PF}/html" install || die
+ dodoc README CHANGELOG || die "doc isntall failed"
+}