summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-13 19:46:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-13 19:46:10 +0000
commitd0e5fd81593b5b447f9ebae40b889ac7f64063d7 (patch)
tree3ff0c7a94d3e9ee0cace53cd9d552064bbd84c95 /dev-ml
parentfixed depend, reverted last stable amd64 x86 commit (diff)
downloadgentoo-2-d0e5fd81593b5b447f9ebae40b889ac7f64063d7.tar.gz
gentoo-2-d0e5fd81593b5b447f9ebae40b889ac7f64063d7.tar.bz2
gentoo-2-d0e5fd81593b5b447f9ebae40b889ac7f64063d7.zip
version bump
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/extlib/ChangeLog7
-rw-r--r--dev-ml/extlib/extlib-1.5.3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/extlib/ChangeLog b/dev-ml/extlib/ChangeLog
index 5d4bab10cd44..1984f2afeb2b 100644
--- a/dev-ml/extlib/ChangeLog
+++ b/dev-ml/extlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/extlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.17 2012/06/30 20:25:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/ChangeLog,v 1.18 2012/08/13 19:46:10 aballier Exp $
+
+*extlib-1.5.3 (13 Aug 2012)
+
+ 13 Aug 2012; Alexis Ballier <aballier@gentoo.org> +extlib-1.5.3.ebuild:
+ version bump
30 Jun 2012; Alexis Ballier <aballier@gentoo.org> extlib-1.5.2.ebuild,
+files/extlib-1.5.2-ocaml4.patch:
diff --git a/dev-ml/extlib/extlib-1.5.3.ebuild b/dev-ml/extlib/extlib-1.5.3.ebuild
new file mode 100644
index 000000000000..0c249def5e9a
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.5.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/extlib/extlib-1.5.3.ebuild,v 1.1 2012/08/13 19:46:10 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
+SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+src_compile() {
+ emake all || die "failed to build"
+ if use ocamlopt; then
+ emake opt || die "failed to build"
+ fi
+
+ if use doc; then
+ emake doc || die "failed to create documentation"
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt || die
+
+ if use doc; then
+ dohtml doc/* || die
+ fi
+}