summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-03-15 20:18:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-03-15 20:18:57 +0000
commitd4bfeff04154804cdb98b781128824a4e8905d33 (patch)
treea441ccc39b7c9f2b8fe9b9d3a0eff38319894773 /dev-ml
parentAdd use deps for libsdl (bug #359079) (diff)
downloadgentoo-2-d4bfeff04154804cdb98b781128824a4e8905d33.tar.gz
gentoo-2-d4bfeff04154804cdb98b781128824a4e8905d33.tar.bz2
gentoo-2-d4bfeff04154804cdb98b781128824a4e8905d33.zip
initial import, ebuild by Vladimir Ivanov, bug #355759, with some modifications by me
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-data-notation/ChangeLog11
-rw-r--r--dev-ml/ocaml-data-notation/metadata.xml9
-rw-r--r--dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.3.ebuild42
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/ocaml-data-notation/ChangeLog b/dev-ml/ocaml-data-notation/ChangeLog
new file mode 100644
index 000000000000..19d1ff1501d0
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocaml-data-notation
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ChangeLog,v 1.1 2011/03/15 20:18:57 aballier Exp $
+
+*ocaml-data-notation-0.0.3 (15 Mar 2011)
+
+ 15 Mar 2011; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-data-notation-0.0.3.ebuild, +metadata.xml:
+ initial import, ebuild by Vladimir Ivanov, bug #355759, with some
+ modifications by me
+
diff --git a/dev-ml/ocaml-data-notation/metadata.xml b/dev-ml/ocaml-data-notation/metadata.xml
new file mode 100644
index 000000000000..f6b3ee22be88
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+<maintainer>
+ <email>v.ivanov@ymail.com</email>
+ <name>Vladimir Ivanov</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.3.ebuild b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.3.ebuild
new file mode 100644
index 000000000000..02b8395173d3
--- /dev/null
+++ b/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-data-notation/ocaml-data-notation-0.0.3.ebuild,v 1.1 2011/03/15 20:18:57 aballier Exp $
+
+EAPI=3
+
+inherit findlib multilib
+
+DESCRIPTION="This project uses type-conv to dump OCaml data structure using OCaml data notation"
+HOMEPAGE="https://forge.ocamlcore.org/projects/odn"
+SRC_URI="https://forge.ocamlcore.org/frs/download.php/505/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-ml/type-conv-1.5.0"
+DEPEND="${RDEPEND}
+ dev-ml/ounit[ocamlopt?]
+ dev-ml/ocaml-fileutils[ocamlopt?]"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ chmod +x configure
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt || die "doc install failed"
+}