summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2014-07-29 14:32:51 +0000
committerMikle Kolyada <zlogene@gentoo.org>2014-07-29 14:32:51 +0000
commit52b4d488d7bdbc98abb882e14c77d2c114a46a3f (patch)
tree281c4d92f72170919823cc1ce5aeeffc6fb76b90 /dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
parentFix finding Python when building in a root, bug #503228. Patch by James Le Cu... (diff)
downloadgentoo-2-52b4d488d7bdbc98abb882e14c77d2c114a46a3f.tar.gz
gentoo-2-52b4d488d7bdbc98abb882e14c77d2c114a46a3f.tar.bz2
gentoo-2-52b4d488d7bdbc98abb882e14c77d2c114a46a3f.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild')
-rw-r--r--dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild b/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
new file mode 100644
index 000000000000..b04f34ff7c9e
--- /dev/null
+++ b/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Alien-SDL/Alien-SDL-1.444.0.ebuild,v 1.1 2014/07/29 14:32:51 zlogene Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=FROGGS
+MODULE_VERSION=1.444
+inherit perl-module
+
+DESCRIPTION="building, finding and using SDL binaries"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+# Archive::Extract, File::Fetch, File::Find, Test::More -> dev-lang/perl
+RDEPEND="dev-perl/Archive-Zip
+ dev-perl/Capture-Tiny
+ dev-perl/File-ShareDir
+ dev-perl/File-Which
+ dev-perl/Text-Patch
+ media-libs/libsdl
+ virtual/perl-Archive-Tar
+ virtual/perl-Digest-SHA
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Module-Build
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp"
+DEPEND=${RDEPEND}
+
+SRC_TEST=do
+myconf='--with-sdl-config'