summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-12-03 03:32:03 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-12-03 03:32:03 +0000
commit91635a0a8fb45a8f5790afb9ae103ee03a747aa0 (patch)
tree3c1f0c0445b5cb6a0fe88fabe6ac702dda86fc8f /dev-perl/Apache-Test/Apache-Test-1.29.ebuild
parentFixed #155152. Patch contributed by Alessandro Di Marco <dmr@gmx.it> (diff)
downloadgentoo-2-91635a0a8fb45a8f5790afb9ae103ee03a747aa0.tar.gz
gentoo-2-91635a0a8fb45a8f5790afb9ae103ee03a747aa0.tar.bz2
gentoo-2-91635a0a8fb45a8f5790afb9ae103ee03a747aa0.zip
Version bump
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'dev-perl/Apache-Test/Apache-Test-1.29.ebuild')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.29.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.29.ebuild b/dev-perl/Apache-Test/Apache-Test-1.29.ebuild
new file mode 100644
index 000000000000..639ede68bcb2
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.29.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.29.ebuild,v 1.1 2006/12/03 03:32:03 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+SRC_URI="mirror://cpan/authors/id/P/PG/PGOLLUCCI/${P}.tar.gz"
+HOMEPAGE="http://cpan.org/modules/by-module/Apache/"
+IUSE=""
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+SRC_TEST="skip"
+
+DEPEND="net-www/apache
+ dev-lang/perl"
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f ${S}/.mypacklist ];
+ then
+ rm -f ${S}/.mypacklist
+ fi
+ perl-module_src_install
+}