summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-15 00:57:49 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-15 00:57:49 +0000
commit1aeccc13fd11b10cc47131177cd9d2aa7cedd655 (patch)
tree2d197cbae6bb5ddf2484bb7095e1d010901c17cd /dev-perl/AxKit
parentreplaced hardcoding of apache path (diff)
downloadgentoo-2-1aeccc13fd11b10cc47131177cd9d2aa7cedd655.tar.gz
gentoo-2-1aeccc13fd11b10cc47131177cd9d2aa7cedd655.tar.bz2
gentoo-2-1aeccc13fd11b10cc47131177cd9d2aa7cedd655.zip
replaced hardcoding of apache path
Diffstat (limited to 'dev-perl/AxKit')
-rw-r--r--dev-perl/AxKit/AxKit-1.5.2-r1.ebuild15
-rw-r--r--dev-perl/AxKit/AxKit-1.6-r1.ebuild13
-rw-r--r--dev-perl/AxKit/AxKit-1.6.ebuild13
-rw-r--r--dev-perl/AxKit/ChangeLog31
4 files changed, 31 insertions, 41 deletions
diff --git a/dev-perl/AxKit/AxKit-1.5.2-r1.ebuild b/dev-perl/AxKit/AxKit-1.5.2-r1.ebuild
index 6748ebb73dd5..67588dccce78 100644
--- a/dev-perl/AxKit/AxKit-1.5.2-r1.ebuild
+++ b/dev-perl/AxKit/AxKit-1.5.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.5.2-r1.ebuild,v 1.10 2002/10/17 16:43:13 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.5.2-r1.ebuild,v 1.11 2002/11/15 00:57:49 vapier Exp $
inherit perl-module
@@ -25,23 +25,22 @@ newdepend ">=dev-perl/libapreq-0.31 \
>=dev-perl/libapreq-1.0 \
>=dev-perl/XML-Sablot-0.50"
+APACHE_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${APACHE_ROOT}" ] && APACHE_ROOT="/home/httpd/htdocs"
+
src_unpack() {
-echo "${PV} | ${P}"
-die
unpack ${A}
cd ${S}
cp Makefile.PL Makefile.PL.orig
sed -e "s:0\.31_03:0.31:" Makefile.PL.orig > Makefile.PL
}
-src_install () {
-
+src_install() {
perl-module_src_install
-
+
diropts -o nobody -g nogroup
dodir /var/cache/axkit
- dodir /home/httpd/htdocs/xslt
+ dodir ${APACHE_ROOT}/xslt
insinto /etc/apache
doins ${FILESDIR}/httpd.axkit
-
}
diff --git a/dev-perl/AxKit/AxKit-1.6-r1.ebuild b/dev-perl/AxKit/AxKit-1.6-r1.ebuild
index bf27ef6968f7..7d2f73453379 100644
--- a/dev-perl/AxKit/AxKit-1.6-r1.ebuild
+++ b/dev-perl/AxKit/AxKit-1.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6-r1.ebuild,v 1.1 2002/10/30 07:20:34 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6-r1.ebuild,v 1.2 2002/11/15 00:57:49 vapier Exp $
inherit perl-module
@@ -26,6 +26,9 @@ newdepend ">=dev-perl/libapreq-0.31 \
>=dev-perl/XML-Sablot-0.50 \
>=dev-perl/Digest-MD5-2.09"
+APACHE_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${APACHE_ROOT}" ] && APACHE_ROOT="/home/httpd/htdocs"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -33,14 +36,12 @@ src_unpack() {
sed -e "s:0\.31_03:0.31:" Makefile.PL.orig > Makefile.PL
}
-src_install () {
-
+src_install() {
perl-module_src_install
-
+
diropts -o nobody -g nogroup
dodir /var/cache/axkit
- dodir /home/httpd/htdocs/xslt
+ dodir ${APACHE_ROOT}/xslt
insinto /etc/apache
doins ${FILESDIR}/httpd.axkit
-
}
diff --git a/dev-perl/AxKit/AxKit-1.6.ebuild b/dev-perl/AxKit/AxKit-1.6.ebuild
index ef7ec1512c32..07eda7802215 100644
--- a/dev-perl/AxKit/AxKit-1.6.ebuild
+++ b/dev-perl/AxKit/AxKit-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6.ebuild,v 1.6 2002/10/23 15:25:10 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6.ebuild,v 1.7 2002/11/15 00:57:49 vapier Exp $
inherit perl-module
@@ -26,6 +26,9 @@ newdepend ">=dev-perl/libapreq-0.31 \
>=dev-perl/XML-Sablot-0.50 \
>=dev-perl/Digest-MD5-2.09"
+APACHE_ROOT="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${APACHE_ROOT}" ] && APACHE_ROOT="/home/httpd/htdocs"
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -33,14 +36,12 @@ src_unpack() {
sed -e "s:0\.31_03:0.31:" Makefile.PL.orig > Makefile.PL
}
-src_install () {
-
+src_install() {
perl-module_src_install
-
+
diropts -o nobody -g nogroup
dodir /var/cache/axkit
- dodir /home/httpd/htdocs/xslt
+ dodir ${APACHE_ROOT}/xslt
insinto /etc/apache
doins ${FILESDIR}/httpd.axkit
-
}
diff --git a/dev-perl/AxKit/ChangeLog b/dev-perl/AxKit/ChangeLog
index f6245c260d02..3ec1940a6e96 100644
--- a/dev-perl/AxKit/ChangeLog
+++ b/dev-perl/AxKit/ChangeLog
@@ -1,31 +1,23 @@
-# ChangeLog for dev-perlAppConfigChangeLog/dev-perlAxKitChangeLog
+# ChangeLog for dev-perl/AxKit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/ChangeLog,v 1.8 2002/10/30 07:20:34 seemant Exp $
-
- 29 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog :
-
- 29 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog : :
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/ChangeLog,v 1.9 2002/11/15 00:57:49 vapier Exp $
- 29 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog : : :
-
- 29 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog : : : :
-
- 29 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog : : : : :
+*AxKit-1.6 (18 Aug 2002)
- 29 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog : : : : : :
+ 14 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Replaced hardcoding of /home/httpd/htdocs with a grep of /etc/apache/conf/apache.conf
+ 29 Oct 2002; Seemant Kulleen <seemant@gentoo.org> ChangeLog :
forced version bump to install into correct locations
-# ChangeLog for dev-perl/AxKit
-
-*AxKit-1.6 (18 Aug 2002)
- 23 Oct 2002; <mcummings@gentoo.org>:
+ 23 Oct 2002; <mcummings@gentoo.org> :
Added sparc64 to keywords. Thawed the build :)
- 18 Aug 2002; <mcummings@gentoo.org> AxKit-1.6.ebuild:
+ 18 Aug 2002; <mcummings@gentoo.org> AxKit-1.6.ebuild :
Added 1.6 ebuild
- 18 Aug 2002; Will Rogers <wjr@wam.umd.edu> AxKit-1.6.ebuild: submitted ebuild
+ 18 Aug 2002; Will Rogers <wjr@wam.umd.edu> AxKit-1.6.ebuild :
+ submitted ebuild
*AxKit-1.5.2-r1 (5 May 2002)
@@ -33,18 +25,15 @@
Updated HOMEPAGE variable since the old one moved
19 Jul 2002; Calum Selkirk <cselkirk@gentoo.org> AxKit-1.5.2-r1.ebuild :
-
Added ppc to KEYWORDS. Removed illegal space characters.
5 May 2002; Seemant Kulleen <seemant@gentoo.org> AxKit-1.5.2-r1.ebuild
files/digest-AxKit-1.5.2-r1 :
-
Changed to use the perl-module.eclass
*AxKit-1.3 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about