summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-27 03:32:57 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-27 03:32:57 +0000
commitf2f08edca74ef6a26bcf64fcd8f74645c0666a96 (patch)
tree48e58cd5f138af279547ca668819175720418c84 /dev-perl/Crypt-RIPEMD160
parentinitial checkin (diff)
downloadgentoo-2-f2f08edca74ef6a26bcf64fcd8f74645c0666a96.tar.gz
gentoo-2-f2f08edca74ef6a26bcf64fcd8f74645c0666a96.tar.bz2
gentoo-2-f2f08edca74ef6a26bcf64fcd8f74645c0666a96.zip
initial checkin
Diffstat (limited to 'dev-perl/Crypt-RIPEMD160')
-rw-r--r--dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.03.ebuild30
-rw-r--r--dev-perl/Crypt-RIPEMD160/files/digest-Crypt-RIPEMD160-0.031
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.03.ebuild b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.03.ebuild
new file mode 100644
index 000000000000..d2a74ddce924
--- /dev/null
+++ b/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.03.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Crypt-RIPEMD160/Crypt-RIPEMD160-0.03.ebuild,v 1.1 2002/01/27 03:28:38 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Crypt::RIPEMD160 module for perl"
+SRC_URI="http://www.cpan.org/authors/id/C/CH/CHGEUER/${P}.tar.gz"
+DEPEND="virtual/glibc >=sys-devel/perl-5"
+
+src_compile() {
+
+ OPTIMIZE="$CFLAGS" perl Makefile.PL
+ make || die
+}
+
+src_install () {
+
+ eval `perl '-V:installarchlib'`
+ mkdir -p ${D}/$installarchlib
+
+ perl Makefile.PL
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+ dodoc ChangeLog MANIFEST README ToDo
+}
diff --git a/dev-perl/Crypt-RIPEMD160/files/digest-Crypt-RIPEMD160-0.03 b/dev-perl/Crypt-RIPEMD160/files/digest-Crypt-RIPEMD160-0.03
new file mode 100644
index 000000000000..0586074dabae
--- /dev/null
+++ b/dev-perl/Crypt-RIPEMD160/files/digest-Crypt-RIPEMD160-0.03
@@ -0,0 +1 @@
+MD5 4572b5ad913fd2e8ec043f0d87448eac Crypt-RIPEMD160-0.03.tar.gz 53248