summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-01-16 10:52:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-01-16 10:52:00 +0000
commit7518d0100479f7a84c325849720cb7df0b4e97d0 (patch)
tree60654a4d21d4b017052e3a791365516dcb196970 /dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild
parentUpdate to new 3.3.0 maintenance release packages, remove first 3.3.0 ebuild (diff)
downloadgentoo-2-7518d0100479f7a84c325849720cb7df0b4e97d0.tar.gz
gentoo-2-7518d0100479f7a84c325849720cb7df0b4e97d0.tar.bz2
gentoo-2-7518d0100479f7a84c325849720cb7df0b4e97d0.zip
Version bump, passes on 8.3 split and 8.2 non-split for me.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-05718-g0556e82 x86_64)
Diffstat (limited to 'dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild
new file mode 100644
index 000000000000..753369026f8f
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.11.8.ebuild,v 1.1 2009/01/16 10:52:00 robbat2 Exp $
+
+MODULE_AUTHOR=TURNSTEP
+inherit perl-module eutils
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/perl-Test-Simple
+ >=virtual/perl-Test-Harness-2.03
+ >=dev-perl/DBI-1.52
+ >=virtual/postgresql-base-7.3"
+
+mydoc="README"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_compile() {
+ postgres_include="$(readlink -f /usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d ${postgres_lib}/${i} ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_compile
+}