summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-06-08 02:49:18 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-06-08 02:49:18 +0000
commit2b766a7a51017cd39a9c58761a52f7930981b1f6 (patch)
tree81601bf2c3df7d579015008359956a179818e5ef /dev-perl/Date-Leapyear/Date-Leapyear-1.71.ebuild
parentCPAN update (diff)
downloadgentoo-2-2b766a7a51017cd39a9c58761a52f7930981b1f6.tar.gz
gentoo-2-2b766a7a51017cd39a9c58761a52f7930981b1f6.tar.bz2
gentoo-2-2b766a7a51017cd39a9c58761a52f7930981b1f6.zip
CPAN update
Diffstat (limited to 'dev-perl/Date-Leapyear/Date-Leapyear-1.71.ebuild')
-rw-r--r--dev-perl/Date-Leapyear/Date-Leapyear-1.71.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-perl/Date-Leapyear/Date-Leapyear-1.71.ebuild b/dev-perl/Date-Leapyear/Date-Leapyear-1.71.ebuild
new file mode 100644
index 000000000000..405411b2ebdb
--- /dev/null
+++ b/dev-perl/Date-Leapyear/Date-Leapyear-1.71.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Date-Leapyear/Date-Leapyear-1.71.ebuild,v 1.1 2003/06/08 02:49:14 mcummings Exp $
+
+inherit perl-module
+
+MY_P=Date-Leapyear-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Simple Perl module that tracks Gregorian leap years"
+SRC_URI="http://www.cpan.org/modules/by-module/Date/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/modules/by-module/Date/${MY_P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
+
+newdepend "dev-perl/Test-Simple"
+
+src_compile() {
+ perl-module_src_compile
+ perl-module_src_test || die "test failed"
+}