summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-09-20 09:55:52 +0000
committerTorsten Veller <tove@gentoo.org>2008-09-20 09:55:52 +0000
commit7c65b7cbdd5f8d0574ea5bb69a982d4d55eeb300 (patch)
tree1f1ae956be705bc615e3223da2af46c191205fd0 /dev-perl/Mail-ClamAV
parentppc stable, bug #218112 (diff)
downloadgentoo-2-7c65b7cbdd5f8d0574ea5bb69a982d4d55eeb300.tar.gz
gentoo-2-7c65b7cbdd5f8d0574ea5bb69a982d4d55eeb300.tar.bz2
gentoo-2-7c65b7cbdd5f8d0574ea5bb69a982d4d55eeb300.zip
Added fix for clamav-0.94. Thanks to Dan Coats (#237939)
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'dev-perl/Mail-ClamAV')
-rw-r--r--dev-perl/Mail-ClamAV/ChangeLog8
-rw-r--r--dev-perl/Mail-ClamAV/Mail-ClamAV-0.22-r1.ebuild25
-rw-r--r--dev-perl/Mail-ClamAV/files/0.22-clamav-0.94.patch98
3 files changed, 130 insertions, 1 deletions
diff --git a/dev-perl/Mail-ClamAV/ChangeLog b/dev-perl/Mail-ClamAV/ChangeLog
index fcede5a7f045..4f276cccf08d 100644
--- a/dev-perl/Mail-ClamAV/ChangeLog
+++ b/dev-perl/Mail-ClamAV/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Mail-ClamAV
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-ClamAV/ChangeLog,v 1.29 2008/09/06 12:06:47 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-ClamAV/ChangeLog,v 1.30 2008/09/20 09:55:52 tove Exp $
+
+*Mail-ClamAV-0.22-r1 (20 Sep 2008)
+
+ 20 Sep 2008; Torsten Veller <tove@gentoo.org>
+ +files/0.22-clamav-0.94.patch, +Mail-ClamAV-0.22-r1.ebuild:
+ Added fix for clamav-0.94. Thanks to Dan Coats (#237939)
06 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
-Mail-ClamAV-0.20.ebuild:
diff --git a/dev-perl/Mail-ClamAV/Mail-ClamAV-0.22-r1.ebuild b/dev-perl/Mail-ClamAV/Mail-ClamAV-0.22-r1.ebuild
new file mode 100644
index 000000000000..0bc361ef1315
--- /dev/null
+++ b/dev-perl/Mail-ClamAV/Mail-ClamAV-0.22-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Mail-ClamAV/Mail-ClamAV-0.22-r1.ebuild,v 1.1 2008/09/20 09:55:52 tove Exp $
+
+MODULE_AUTHOR=SABECK
+inherit perl-module eutils
+
+DESCRIPTION="Perl extension for the clamav virus scanner."
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-antivirus/clamav-0.94
+ dev-perl/Inline
+ dev-lang/perl"
+
+PATCHES=( "${FILESDIR}"/0.22-clamav-0.94.patch )
+SRC_TEST=do
+
+src_install() {
+ perl-module_src_install
+ dodoc README || die
+}
diff --git a/dev-perl/Mail-ClamAV/files/0.22-clamav-0.94.patch b/dev-perl/Mail-ClamAV/files/0.22-clamav-0.94.patch
new file mode 100644
index 000000000000..03f1ccaca372
--- /dev/null
+++ b/dev-perl/Mail-ClamAV/files/0.22-clamav-0.94.patch
@@ -0,0 +1,98 @@
+http://rt.cpan.org/Ticket/Display.html?id=39301
+
+--- ./t/Mail-ClamAV.t.orig 2008-09-15 10:51:16.000000000 -0700
++++ ./t/Mail-ClamAV.t 2008-09-15 10:52:03.000000000 -0700
+@@ -29,7 +29,6 @@
+ CL_EACCES
+ CL_ENULLARG
+ CL_ETMPFILE
+- CL_EFSYNC
+ CL_EMEM
+ CL_EOPEN
+ CL_EMALFDB
+@@ -42,7 +41,6 @@
+ CL_EIO
+ CL_EFORMAT
+ CL_ESUPPORT
+- CL_ELOCKDB
+
+ CL_ENCINIT
+ CL_ENCLOAD
+--- ./ClamAV.pm.orig 2008-09-15 10:51:16.000000000 -0700
++++ ./ClamAV.pm 2008-09-15 10:52:52.000000000 -0700
+@@ -58,7 +58,6 @@
+ CL_EACCES
+ CL_ENULLARG
+ CL_ETMPFILE
+- CL_EFSYNC
+ CL_EMEM
+ CL_EOPEN
+ CL_EMALFDB
+@@ -71,7 +70,6 @@
+ CL_EIO
+ CL_EFORMAT
+ CL_ESUPPORT
+- CL_ELOCKDB
+
+ CL_ENCINIT
+ CL_ENCLOAD
+@@ -478,7 +476,6 @@
+ if (strEQ("CL_EACCES", name)) return CL_EACCES;
+ if (strEQ("CL_ENULLARG", name)) return CL_ENULLARG;
+ if (strEQ("CL_ETMPFILE", name)) return CL_ETMPFILE;
+- if (strEQ("CL_EFSYNC", name)) return CL_EFSYNC;
+ if (strEQ("CL_EMEM", name)) return CL_EMEM;
+ if (strEQ("CL_EOPEN", name)) return CL_EOPEN;
+ if (strEQ("CL_EMALFDB", name)) return CL_EMALFDB;
+@@ -491,7 +488,6 @@
+ if (strEQ("CL_EIO", name)) return CL_EIO;
+ if (strEQ("CL_EFORMAT", name)) return CL_EFORMAT;
+ if (strEQ("CL_ESUPPORT", name)) return CL_ESUPPORT;
+- if (strEQ("CL_ELOCKDB", name)) return CL_ELOCKDB;
+
+ /* NodalCore */
+ if (strEQ("CL_ENCINIT", name)) return CL_ENCINIT;
+@@ -788,10 +784,6 @@
+
+ tmpfile() failed
+
+-=item CL_EFSYNC
+-
+-fsync() failed
+-
+ =item CL_EMEM
+
+ memory allocation error
+@@ -840,10 +832,6 @@
+
+ not supported data format
+
+-=item CL_ELOCKDB
+-
+-can't lock DB directory
+-
+ =item CL_ENCINIT
+
+ NodalCore initialization failed
+--- ./README.orig 2008-09-15 10:51:16.000000000 -0700
++++ ./README 2008-09-15 10:53:05.000000000 -0700
+@@ -170,9 +170,6 @@
+ CL_ETMPFILE
+ tmpfile() failed
+
+- CL_EFSYNC
+- fsync() failed
+-
+ CL_EMEM
+ memory allocation error
+
+@@ -209,9 +206,6 @@
+ CL_ESUPPORT
+ not supported data format
+
+- CL_ELOCKDB
+- can't lock DB directory
+-
+ CL_ENCINIT
+ NodalCore initialization failed
+