summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2014-07-15 10:34:05 +0000
committerMikle Kolyada <zlogene@gentoo.org>2014-07-15 10:34:05 +0000
commitba1728ad54396726f86d934cb4572159d67dedd1 (patch)
tree5265ab0129d4c4ac623bd3b3c69a2f1badce3446 /dev-perl/Net-SSLeay/Net-SSLeay-1.650.0.ebuild
parentVersion bump, drop old (diff)
downloadgentoo-2-ba1728ad54396726f86d934cb4572159d67dedd1.tar.gz
gentoo-2-ba1728ad54396726f86d934cb4572159d67dedd1.tar.bz2
gentoo-2-ba1728ad54396726f86d934cb4572159d67dedd1.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.650.0.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.650.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.650.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.650.0.ebuild
new file mode 100644
index 000000000000..f04fe51c4203
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.650.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-SSLeay/Net-SSLeay-1.650.0.ebuild,v 1.1 2014/07/15 10:34:05 zlogene Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=MIKEM
+MODULE_VERSION=1.65
+inherit multilib perl-module
+
+DESCRIPTION="Net::SSLeay module for perl"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Exception
+# dev-perl/Test-Warn
+# dev-perl/Test-NoWarnings )"
+
+#SRC_TEST=do
+
+export OPTIMIZE="$CFLAGS"
+export OPENSSL_PREFIX=${EPREFIX}/usr
+
+src_prepare() {
+ sed -i \
+ -e "/\$opts->{optimize} = '-O2 -g';/d" \
+ -e "s,\"\$prefix/lib\",\"\$prefix/$(get_libdir)\"," \
+ inc/Module/Install/PRIVATE/Net/SSLeay.pm || die
+ perl-module_src_prepare
+}