summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-10 00:29:58 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-10 00:29:58 +0000
commit0b6db084d41edfcd30195a73b0e7a201fde18356 (patch)
treeb3907da605291e25ed7d3b99f3c960b494f1105a /dev-perl/PDL
parent-fixes, etc... (diff)
downloadgentoo-2-0b6db084d41edfcd30195a73b0e7a201fde18356.tar.gz
gentoo-2-0b6db084d41edfcd30195a73b0e7a201fde18356.tar.bz2
gentoo-2-0b6db084d41edfcd30195a73b0e7a201fde18356.zip
...
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/PDL-2.2.1.ebuild59
1 files changed, 29 insertions, 30 deletions
diff --git a/dev-perl/PDL/PDL-2.2.1.ebuild b/dev-perl/PDL/PDL-2.2.1.ebuild
index 12ad243c85d9..88c76ce185ac 100644
--- a/dev-perl/PDL/PDL-2.2.1.ebuild
+++ b/dev-perl/PDL/PDL-2.2.1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.2.1.ebuild,v 1.2 2001/09/26 06:46:49 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.2.1.ebuild,v 1.3 2001/11/10 00:29:58 hallski Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="PDL Perl Module"
-SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${A}"
+SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${P}.tar.gz"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
DEPEND=">=sys-devel/perl-5
@@ -15,43 +14,43 @@ DEPEND=">=sys-devel/perl-5
# opengl? ( virtual/opengl virtual/glu )
src_unpack() {
-
- unpack ${A}
-
- #open gl does not work at the moment
- if [ "`use opengl`" ]
- then
- echo "OpenGL support is current disabled due to build issues"
- sed -e "s:WITH_3D => undef:WITH_3D => 0:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
- else
- sed -e "s:WITH_3D => undef:WITH_3D => 0:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
- fi
-
+ unpack ${A}
+
+ #open gl does not work at the moment
+ if [ "`use opengl`" ]
+ then
+ echo "OpenGL support is current disabled due to build issues"
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ else
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ fi
}
src_compile() {
+ perl Makefile.PL
- perl Makefile.PL
- try make
- make test
-
+ make || die
+ make test || die
}
src_install () {
+ make PREFIX=${D}/usr \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ install || die
+
+ dodoc COPYING Changes DEPENDENCIES DEVELOPMENT README MANIFEST*
- try make PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- INSTALLMAN1DIR=${D}/usr/share/man/man1 install
+ dodoc Release_Notes TODO
+ mv ${D}/usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/HtmlDocs ${D}/usr/doc/${P}/html
+ mydir=${D}/usr/doc/${P}/html/PDL
- dodoc COPYING Changes DEPENDENCIES DEVELOPMENT README MANIFEST*
- dodoc Release_Notes TODO
- mv ${D}/usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/HtmlDocs ${D}/usr/doc/${P}/html
- mydir=${D}/usr/doc/${P}/html/PDL
- for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
- do
- dosed ${i/${D}}
- done
- dosed /usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/pdldoc.db
+ for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
+ do
+ dosed ${i/${D}}
+ done
+ dosed /usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/pdldoc.db
}