summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-11-12 20:02:34 +0000
committerTorsten Veller <tove@gentoo.org>2012-11-12 20:02:34 +0000
commit42dc0ee46dbc6e9b3a6bbd3869cab40ef4a24573 (patch)
treee6ae3c3dabfcc610bdd6312ac2c204216c6f5dbd /dev-perl/RadiusPerl/RadiusPerl-0.220.0.ebuild
parent[bump] dev-perl/ShipIt-0.580.0 (diff)
downloadgentoo-2-42dc0ee46dbc6e9b3a6bbd3869cab40ef4a24573.tar.gz
gentoo-2-42dc0ee46dbc6e9b3a6bbd3869cab40ef4a24573.tar.bz2
gentoo-2-42dc0ee46dbc6e9b3a6bbd3869cab40ef4a24573.zip
[bump] dev-perl/RadiusPerl-0.220.0
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0x5772769F4E046AEC)
Diffstat (limited to 'dev-perl/RadiusPerl/RadiusPerl-0.220.0.ebuild')
-rw-r--r--dev-perl/RadiusPerl/RadiusPerl-0.220.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/RadiusPerl/RadiusPerl-0.220.0.ebuild b/dev-perl/RadiusPerl/RadiusPerl-0.220.0.ebuild
new file mode 100644
index 000000000000..a302ec75a4dd
--- /dev/null
+++ b/dev-perl/RadiusPerl/RadiusPerl-0.220.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RadiusPerl/RadiusPerl-0.220.0.ebuild,v 1.1 2012/11/12 20:02:34 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=MANOWAR
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.12
+ >=dev-perl/Data-HexDump-0.02
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/Authen-Radius-${MODULE_VERSION}
+
+SRC_TEST="do"
+export OPTIMIZE="$CFLAGS"
+PATCHES=( "${FILESDIR}"/dictionary.cisco.ssg.patch )
+
+src_prepare() {
+ sed -i '/install-radius-db.PL/d' Makefile.PL MANIFEST || die
+ mv "${S}"/install-radius-db.PL{,.orig} || die
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}