summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-01-31 12:30:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-01-31 12:30:57 +0000
commitcd16ed69028ee194626cff63d7025ad3e28e4c19 (patch)
treed9d6d28dcb44693d44779873c63a13d4383e6acb /dev-perl/Search-Xapian/Search-Xapian-1.2.17.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-cd16ed69028ee194626cff63d7025ad3e28e4c19.tar.gz
gentoo-2-cd16ed69028ee194626cff63d7025ad3e28e4c19.tar.bz2
gentoo-2-cd16ed69028ee194626cff63d7025ad3e28e4c19.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-perl/Search-Xapian/Search-Xapian-1.2.17.0.ebuild')
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.17.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.17.0.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.17.0.ebuild
new file mode 100644
index 000000000000..11d59ce93fa9
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.17.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Search-Xapian/Search-Xapian-1.2.17.0.ebuild,v 1.1 2014/01/31 12:30:57 blueness Exp $
+
+EAPI="5"
+
+MODULE_AUTHOR=OLLY
+inherit perl-module toolchain-funcs versionator
+
+VERSION=$(get_version_component_range 1-3)
+
+SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library."
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="~dev-libs/xapian-${VERSION}
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build"
+
+SRC_TEST="do"
+
+myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}