summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-11-29 18:35:34 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-11-29 18:35:34 +0000
commita70556e6cc40dab92ae931ca82574ad0926fb2d5 (patch)
tree68a0527a2c8f67bab1846ce6055c95a37f1619d3 /dev-perl/gtk-perl/gtk-perl-0.7008-r9.ebuild
parentNew version (diff)
downloadgentoo-2-a70556e6cc40dab92ae931ca82574ad0926fb2d5.tar.gz
gentoo-2-a70556e6cc40dab92ae931ca82574ad0926fb2d5.tar.bz2
gentoo-2-a70556e6cc40dab92ae931ca82574ad0926fb2d5.zip
big typo on my part
Diffstat (limited to 'dev-perl/gtk-perl/gtk-perl-0.7008-r9.ebuild')
-rw-r--r--dev-perl/gtk-perl/gtk-perl-0.7008-r9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/gtk-perl/gtk-perl-0.7008-r9.ebuild b/dev-perl/gtk-perl/gtk-perl-0.7008-r9.ebuild
new file mode 100644
index 000000000000..4aacda163b2d
--- /dev/null
+++ b/dev-perl/gtk-perl/gtk-perl-0.7008-r9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl/gtk-perl-0.7008-r9.ebuild,v 1.1 2002/11/29 18:35:34 mcummings Exp $
+
+inherit perl-module
+
+MY_P=Gtk-Perl-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl bindings for GTK"
+SRC_URI="http://www.gtkperl.org/${MY_P}.tar.gz"
+HOMEPAGE="http://www.perl.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="${DEPEND}
+ media-libs/gdk-pixbuf
+ =x11-libs/gtk+-1.2*
+ dev-perl/XML-Writer
+ dev-perl/XML-Parser
+ gnome? ( gnome-base/gnome-libs )"
+
+mydoc="VERSIONS WARNING NOTES"
+
+use gnome || myconf="${myconf} --without-gnome --without-gnomeprint --without-applets"
+
+src_unpack() {
+
+ unpack ${A}
+ # Fix gdk-pixbuf-0.20.0 not detected, bug #10232.
+ cd ${S}; patch -p1 < ${FILESDIR}/${P}-gdkpixbuf-detect-fix.patch || die
+ cd ${S}
+ cp Makefile.PL Makefile.PL.bak
+ perl -pi -e '/CCMD/ && s|/m;|/mg;|' */Makefile.PL
+ cd ${S}
+ perl Makefile.PL ${myconf} \
+ PREFIX=${D}/usr
+}
+
+
+src_compile() {
+
+ make ${mymake} || die "compilation failed"
+}