summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-06-23 20:17:41 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-06-23 20:17:41 +0000
commit899838067b46521d6f0985d36975c0cf4a8839da (patch)
tree046a833755f6505f306b4b60d3b5b4a91b43ee44 /dev-perl/math-pari/math-pari-2.010706.ebuild
parentVersion bump upstream (diff)
downloadgentoo-2-899838067b46521d6f0985d36975c0cf4a8839da.tar.gz
gentoo-2-899838067b46521d6f0985d36975c0cf4a8839da.tar.bz2
gentoo-2-899838067b46521d6f0985d36975c0cf4a8839da.zip
Version bump upstream
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'dev-perl/math-pari/math-pari-2.010706.ebuild')
-rw-r--r--dev-perl/math-pari/math-pari-2.010706.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/math-pari/math-pari-2.010706.ebuild b/dev-perl/math-pari/math-pari-2.010706.ebuild
new file mode 100644
index 000000000000..8aed1c9c6a3a
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010706.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.1 2006/06/23 20:17:40 mcummings Exp $
+
+inherit perl-module eutils
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+SRC_URI="mirror://cpan/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-2.1.7.tgz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+DEPEND="~sci-mathematics/pari-2.1.7"
+