summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-07-10 02:05:47 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-07-10 02:05:47 +0000
commit608e1e171bf7053bafcf98a0c2894eea26557824 (patch)
treea266c7fc3cd8c554630bfe49078ba2fe7e2543bb /dev-perl/math-pari
parentgames-ded goes in by default (diff)
downloadgentoo-2-608e1e171bf7053bafcf98a0c2894eea26557824.tar.gz
gentoo-2-608e1e171bf7053bafcf98a0c2894eea26557824.tar.bz2
gentoo-2-608e1e171bf7053bafcf98a0c2894eea26557824.zip
bug 24073
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog12
-rw-r--r--dev-perl/math-pari/files/digest-math-pari-2.010500-r12
-rw-r--r--dev-perl/math-pari/math-pari-2.010500-r1.ebuild24
3 files changed, 37 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 8d3c04239b2d..41c411ac3cd5 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-perl/math-pari
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.2 2003/06/24 10:29:36 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.3 2003/07/10 02:05:47 mcummings Exp $
+
+*math-pari-2.010500-r1 (09 Jul 2003)
+
+ 09 Jul 2003; Michael Cummings <mcummings@gentoo.org>
+ math-pari-2.010500-r1.ebuild:
+ Unfortunately it appears my "elegant" solution to the pari depend doesn't work
+ if pari isn't installed first (the DEPEND is not read prior to the SRC_URI as
+ I had thought). The new version instead is hard DEPEND'ed against a particular
+ version as both versions of app-sci/pari have identical KEYWORDs. This
+ should handle bug 24073.
24 Jun 2003; Michael Cummings <mcummings@gentoo.org>
math-pari-2.010500.ebuild:
diff --git a/dev-perl/math-pari/files/digest-math-pari-2.010500-r1 b/dev-perl/math-pari/files/digest-math-pari-2.010500-r1
new file mode 100644
index 000000000000..d2d15dba5aa6
--- /dev/null
+++ b/dev-perl/math-pari/files/digest-math-pari-2.010500-r1
@@ -0,0 +1,2 @@
+MD5 6ae5d0b044984a4fdc7817e79922419e Math-Pari-2.010500.tar.gz 91295
+MD5 194e9d1cc11926e457028c6a7cba15f0 pari-2.1.5.tar.gz 1540679
diff --git a/dev-perl/math-pari/math-pari-2.010500-r1.ebuild b/dev-perl/math-pari/math-pari-2.010500-r1.ebuild
new file mode 100644
index 000000000000..47b33c2f26d9
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010500-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010500-r1.ebuild,v 1.1 2003/07/10 02:05:47 mcummings Exp $
+
+inherit perl-module
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+SRC_URI="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://www.gn-50uma.de/ftp/pari-2.1/pari-2.1.5.tar.gz"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+
+DEPEND="=app-sci/pari-2.1.5"
+