summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-07-11 20:59:54 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-07-11 20:59:54 +0000
commitc06d6ca4ae99d01e750bdf47c18f25448820e6dc (patch)
treee026045496d9f7de836bfd8861d1c4180bbfef67 /dev-perl/math-pari
parentAdd missing changelog entry (diff)
downloadgentoo-2-c06d6ca4ae99d01e750bdf47c18f25448820e6dc.tar.gz
gentoo-2-c06d6ca4ae99d01e750bdf47c18f25448820e6dc.tar.bz2
gentoo-2-c06d6ca4ae99d01e750bdf47c18f25448820e6dc.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0B08240A96F66571)
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog10
-rw-r--r--dev-perl/math-pari/math-pari-2.10.808.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index b63f2d863bf0..2c3683185854 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.78 2014/08/22 15:44:03 axs Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.79 2015/07/11 20:59:54 dilfridge Exp $
+
+*math-pari-2.10.808 (11 Jul 2015)
+
+ 11 Jul 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ +math-pari-2.10.808.ebuild:
+ Version bump
*math-pari-2.10.806.50-r1 (22 Aug 2014)
diff --git a/dev-perl/math-pari/math-pari-2.10.808.ebuild b/dev-perl/math-pari/math-pari-2.10.808.ebuild
new file mode 100644
index 000000000000..522ff653882a
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.10.808.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.10.808.ebuild,v 1.1 2015/07/11 20:59:54 dilfridge Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=ILYAZ
+MODULE_SECTION=modules
+MODULE_VERSION=2.010808
+MODULE_A_EXT=zip
+MY_PN=Math-Pari
+inherit perl-module toolchain-funcs
+
+PARI_VER=2.3.5
+
+DESCRIPTION="Perl interface to PARI"
+SRC_URI="${SRC_URI}
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-${PARI_VER}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+RDEPEND="~sci-mathematics/pari-${PARI_VER}"
+DEPEND="${RDEPEND}"
+
+S_PARI=${WORKDIR}/pari-${PARI_VER}
+SRC_TEST=do
+
+src_prepare() {
+ # On 64-bit hardware, these files are needed in both the 64/ and 32/
+ # directories for the testsuite to pass.
+ cd "${S_PARI}"/src/test/
+ for t in analyz compat ellglobalred elliptic galois graph intnum kernel \
+ linear nfields number objets ploth polyser program qfbsolve rfrac \
+ round4 stark sumiter trans ; do
+ i="in/${t}"
+ o32="32/${t}"
+ o64="64/${t}"
+ [ -f "$i" -a ! -f "$o32" ] && cp -al "$i" "$o32"
+ [ -f "$i" -a ! -f "$o64" ] && cp -al "$i" "$o64"
+ done
+ perl-module_src_prepare
+}
+
+src_configure() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_configure
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}