summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2007-09-11 17:11:43 +0000
committerJeroen Roovers <jer@gentoo.org>2007-09-11 17:11:43 +0000
commit0e0279bd164695dfdbb91eeee32b0a7af7112a92 (patch)
treecf6ab0b4cdbb14f2818a7f32dfabecfdd758f582 /dev-perl
parentTurn sed script into patch (bug #180807). (diff)
downloadgentoo-2-0e0279bd164695dfdbb91eeee32b0a7af7112a92.tar.gz
gentoo-2-0e0279bd164695dfdbb91eeee32b0a7af7112a92.tar.bz2
gentoo-2-0e0279bd164695dfdbb91eeee32b0a7af7112a92.zip
Fix automagic, clean up ebuild, add TODOs.
(Portage version: 2.1.2.12)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/PDL/ChangeLog6
-rw-r--r--dev-perl/PDL/PDL-2.4.3-r1.ebuild23
-rw-r--r--dev-perl/PDL/files/gsl.patch14
3 files changed, 22 insertions, 21 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index 40e738b9bab1..15baaf57c89c 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/PDL
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.75 2007/09/11 16:38:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.76 2007/09/11 17:11:42 jer Exp $
+
+ 11 Sep 2007; Jeroen Roovers <jer@gentoo.org> -files/gsl.patch,
+ PDL-2.4.3-r1.ebuild:
+ Fix automagic, clean up ebuild, add TODOs.
11 Sep 2007; Jeroen Roovers <jer@gentoo.org> +files/PDL-2.4.3-PIC.patch,
PDL-2.4.3-r1.ebuild:
diff --git a/dev-perl/PDL/PDL-2.4.3-r1.ebuild b/dev-perl/PDL/PDL-2.4.3-r1.ebuild
index 607747e9fad6..91ee75d4a02a 100644
--- a/dev-perl/PDL/PDL-2.4.3-r1.ebuild
+++ b/dev-perl/PDL/PDL-2.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.3-r1.ebuild,v 1.12 2007/09/11 16:38:06 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.3-r1.ebuild,v 1.13 2007/09/11 17:11:42 jer Exp $
inherit perl-module eutils multilib
@@ -31,8 +31,16 @@ mydoc="DEPENDENCIES DEVELOPMENT MANIFEST* Release_Notes TODO"
src_unpack() {
unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/PDL-2.4.2-makemakerfix.patch"
+
+ # Unconditional -fPIC for the lib (#55238, #180807)
+ epatch "${FILESDIR}/${P}-PIC.patch"
+
+ # TODO: everything in this function below this
+ # TODO: line really belongs in src_compile() :
- cd ${S}; epatch ${FILESDIR}/PDL-2.4.2-makemakerfix.patch
# This 'fix' breaks compiles for non-opengl users
#if ! use opengl ; then
# sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
@@ -40,12 +48,15 @@ src_unpack() {
#fi
if use badval ; then
- sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" \
- ${S}/perldl.conf
+ sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" "${S}/perldl.conf"
fi
- # Unconditional -fPIC for the lib (#55238, #180807)
- epatch "${FILESDIR}/${P}-PIC.patch"
+ # Turn off GSL automagic:
+ if use gsl ; then
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 1:" "${S}/perldl.conf"
+ else
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 0:" "${S}/perldl.conf"
+ fi
}
src_install() {
diff --git a/dev-perl/PDL/files/gsl.patch b/dev-perl/PDL/files/gsl.patch
deleted file mode 100644
index 87c74446a604..000000000000
--- a/dev-perl/PDL/files/gsl.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- perldl.conf.old 2004-01-07 23:47:08.000000000 -0500
-+++ perldl.conf 2004-01-07 23:35:33.000000000 -0500
-@@ -85,9 +85,9 @@
- WITH_GSL => undef, # Leave it up to PDL to decide
-
- # Location to search for the GSL libs
-- GSL_LIBS => [ '/lib','/usr/lib','/usr/local/lib'],
-+ GSL_LIBS => undef,
- # Location to find GSL includes:
-- GSL_INC => '-I/usr/include/gsl -I/usr/local/include',
-+ GSL_INC => undef,
-
- # Whether or not to build the PDL::FFTW module
- # 0 -> don't use