summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-02-13 14:25:10 +0000
committerTorsten Veller <tove@gentoo.org>2012-02-13 14:25:10 +0000
commit44b273f157701c85be2032cc766efb0db8bd0c5c (patch)
tree1e6de0d3cf4b7a4c0d3394971c70db99a898f6a0 /dev-perl
parentInitial commit for Class-Load and Params-Validate (diff)
downloadgentoo-2-44b273f157701c85be2032cc766efb0db8bd0c5c.tar.gz
gentoo-2-44b273f157701c85be2032cc766efb0db8bd0c5c.tar.bz2
gentoo-2-44b273f157701c85be2032cc766efb0db8bd0c5c.zip
[bump] dev-perl/Class-Load-0.170.0
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Class-Load/ChangeLog9
-rw-r--r--dev-perl/Class-Load/Class-Load-0.170.0.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-perl/Class-Load/ChangeLog b/dev-perl/Class-Load/ChangeLog
index 45a90bb07eb4..c83f05318a91 100644
--- a/dev-perl/Class-Load/ChangeLog
+++ b/dev-perl/Class-Load/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Class-Load
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Class-Load/ChangeLog,v 1.18 2011/12/25 11:54:14 tove Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Class-Load/ChangeLog,v 1.19 2012/02/13 14:25:10 tove Exp $
+
+*Class-Load-0.170.0 (13 Feb 2012)
+
+ 13 Feb 2012; Torsten Veller <tove@gentoo.org> +Class-Load-0.170.0.ebuild:
+ Version bump
*Class-Load-0.130.0 (25 Dec 2011)
diff --git a/dev-perl/Class-Load/Class-Load-0.170.0.ebuild b/dev-perl/Class-Load/Class-Load-0.170.0.ebuild
new file mode 100644
index 000000000000..20f4d253b235
--- /dev/null
+++ b/dev-perl/Class-Load/Class-Load-0.170.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Class-Load/Class-Load-0.170.0.ebuild,v 1.1 2012/02/13 14:25:10 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.17
+inherit perl-module
+
+DESCRIPTION="A working (require q{Class::Name}) and more"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Data-OptList
+ >=dev-perl/Module-Runtime-0.12.0
+ >=dev-perl/Module-Implementation-0.40.0
+ >=dev-perl/Package-Stash-0.320.0
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ )"
+
+SRC_TEST="do"