summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-21 16:35:30 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-21 16:35:30 +0000
commit4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed (patch)
treeb61465d6a7c6cbe5e89ed0ea532cd8ad079c35a0 /dev-perl
parentUpgrade. Fixes string vulnerability exploit. (diff)
downloadgentoo-2-4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed.tar.gz
gentoo-2-4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed.tar.bz2
gentoo-2-4a7828c7f6bb761f072bd29c8b6d17fa91c1f8ed.zip
New version
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/XML-Sablot/XML-Sablot-0.60.ebuild43
-rw-r--r--dev-perl/XML-Sablot/files/digest-XML-Sablot-0.601
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/XML-Sablot/XML-Sablot-0.60.ebuild b/dev-perl/XML-Sablot/XML-Sablot-0.60.ebuild
new file mode 100644
index 000000000000..fa217ba15b54
--- /dev/null
+++ b/dev-perl/XML-Sablot/XML-Sablot-0.60.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Sablot/XML-Sablot-0.60.ebuild,v 1.1 2001/06/21 16:35:16 achim Exp $
+
+P=XML-Sablotron-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="dev-perl"
+DESCRIPTION="Perl Module for Sablotron"
+#SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${A}"
+#HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/xml-sab.act"
+SRC_URI="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${A}"
+HOMEPAGE="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${PN}.${PV}.readme"
+
+DEPEND=">=sys-devel/perl-5
+ >=app-text/sablotron-0.60"
+
+src_unpack() {
+
+ unpack ${A}
+
+}
+
+src_compile() {
+
+ perl Makefile.PL
+ try make
+ try make test
+
+}
+
+src_install () {
+
+ try make PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 install
+ dodoc Changes README MANIFEST
+}
+
+
+
+
+
+
diff --git a/dev-perl/XML-Sablot/files/digest-XML-Sablot-0.60 b/dev-perl/XML-Sablot/files/digest-XML-Sablot-0.60
new file mode 100644
index 000000000000..c99771313a20
--- /dev/null
+++ b/dev-perl/XML-Sablot/files/digest-XML-Sablot-0.60
@@ -0,0 +1 @@
+MD5 ba12386541f721561b45e2ff3f6e745c XML-Sablotron-0.60.tar.gz