summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-01-23 13:33:50 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-01-23 13:33:50 +0000
commit4bb7f8de7c93cdbc10a6f3a1408f065338b261bc (patch)
tree7903cb45e193c52c20a3ac215567f698f79e9a2e /dev-perl
parentFixed dependencies, see bug #163421. (diff)
downloadgentoo-2-4bb7f8de7c93cdbc10a6f3a1408f065338b261bc.tar.gz
gentoo-2-4bb7f8de7c93cdbc10a6f3a1408f065338b261bc.tar.bz2
gentoo-2-4bb7f8de7c93cdbc10a6f3a1408f065338b261bc.zip
Version bump
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/module-build/ChangeLog8
-rw-r--r--dev-perl/module-build/files/digest-module-build-0.28.063
-rw-r--r--dev-perl/module-build/module-build-0.28.06.ebuild29
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-perl/module-build/ChangeLog b/dev-perl/module-build/ChangeLog
index 5af0718b1611..ab75daeaf886 100644
--- a/dev-perl/module-build/ChangeLog
+++ b/dev-perl/module-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/module-build
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.56 2007/01/21 15:49:48 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/ChangeLog,v 1.57 2007/01/23 13:33:50 mcummings Exp $
+
+*module-build-0.28.06 (23 Jan 2007)
+
+ 23 Jan 2007; Michael Cummings <mcummings@gentoo.org>
+ +module-build-0.28.06.ebuild:
+ Version bump
21 Jan 2007; Michael Cummings <mcummings@gentoo.org>
-module-build-0.25.ebuild, -module-build-0.26.10.ebuild,
diff --git a/dev-perl/module-build/files/digest-module-build-0.28.06 b/dev-perl/module-build/files/digest-module-build-0.28.06
new file mode 100644
index 000000000000..09a08ae18c22
--- /dev/null
+++ b/dev-perl/module-build/files/digest-module-build-0.28.06
@@ -0,0 +1,3 @@
+MD5 919a54ab295329ab668fae14756ae80a Module-Build-0.2806.tar.gz 189963
+RMD160 4e3d8e3cb19725daa638732cfcadd3565f853a1c Module-Build-0.2806.tar.gz 189963
+SHA256 e37767199d6ee5af4c7ce267bcf95767cac41a7ce193a9868afeb2599c3385b7 Module-Build-0.2806.tar.gz 189963
diff --git a/dev-perl/module-build/module-build-0.28.06.ebuild b/dev-perl/module-build/module-build-0.28.06.ebuild
new file mode 100644
index 000000000000..1fefc2a37da3
--- /dev/null
+++ b/dev-perl/module-build/module-build-0.28.06.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.28.06.ebuild,v 1.1 2007/01/23 13:33:50 mcummings Exp $
+
+inherit versionator perl-module
+
+MY_PV="$(delete_version_separator 2)"
+MY_P="Module-Build-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Build and install Perl modules"
+HOMEPAGE="http://search.cpan.org/~kwilliams/"
+SRC_URI="mirror://cpan/authors/id/K/KW/KWILLIAMS/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Removing these as hard deps. They are listed as recommended in the Build.PL,
+# but end up causing a dep loop since they require module-build to be built.
+# ~mcummings 06.16.06
+PDEPEND=">=dev-perl/ExtUtils-CBuilder-0.15
+ >=dev-perl/extutils-parsexs-1.02"
+
+DEPEND="dev-lang/perl
+ dev-perl/yaml
+ >=dev-perl/Archive-Tar-1.09"
+
+SRC_TEST="do"