summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2014-10-01 13:53:40 +0000
committerBrian Evans <grknight@gentoo.org>2014-10-01 13:53:40 +0000
commitac9758e3b5e14c39e4777b4a83c621bf6d93450a (patch)
tree3191816b95c7de8e6b6fdb9429b8bb67fa2d6bff /dev-php/pecl-eio/pecl-eio-1.2.5.ebuild
parentRevbump to drop 5.3 support wrt bug 524122 on behalf of Ruslan Osmanov <rrosm... (diff)
downloadgentoo-2-ac9758e3b5e14c39e4777b4a83c621bf6d93450a.tar.gz
gentoo-2-ac9758e3b5e14c39e4777b4a83c621bf6d93450a.tar.bz2
gentoo-2-ac9758e3b5e14c39e4777b4a83c621bf6d93450a.zip
Version bump to 1.2.5 wrt bug 524122 on behalf of Ruslan Osmanov <rrosmanov@gmail.com>
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 67C78E1D)
Diffstat (limited to 'dev-php/pecl-eio/pecl-eio-1.2.5.ebuild')
-rw-r--r--dev-php/pecl-eio/pecl-eio-1.2.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/pecl-eio/pecl-eio-1.2.5.ebuild b/dev-php/pecl-eio/pecl-eio-1.2.5.ebuild
new file mode 100644
index 000000000000..3a30480e0039
--- /dev/null
+++ b/dev-php/pecl-eio/pecl-eio-1.2.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-eio/pecl-eio-1.2.5.ebuild,v 1.1 2014/10/01 13:53:40 grknight Exp $
+
+EAPI=5
+PHP_EXT_NAME="eio"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL INSTALL README LICENSE"
+
+USE_PHP="php5-4 php5-5 php5-6"
+inherit php-ext-pecl-r2 confutils
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libeio library"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="debug"
+
+src_configure() {
+ my_conf="--with-eio"
+ enable_extension_enable "eio-debug" "debug" 0
+
+ php-ext-source-r2_src_configure
+}