summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2013-12-09 21:34:18 +0000
committerMatti Bickel <mabi@gentoo.org>2013-12-09 21:34:18 +0000
commita94d6c6a09da6a6669e23ebf275310e7d886c7c3 (patch)
tree1754a8c5b40db80e96435bfa846a7ca8dfd600d9 /dev-php/pecl-haru
parentversion bump, eapi bump; Replace custom src_unpack by setting S/PHP_EXT_S acc... (diff)
downloadgentoo-2-a94d6c6a09da6a6669e23ebf275310e7d886c7c3.tar.gz
gentoo-2-a94d6c6a09da6a6669e23ebf275310e7d886c7c3.tar.bz2
gentoo-2-a94d6c6a09da6a6669e23ebf275310e7d886c7c3.zip
version bump, now detects haru correctly
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xDDF971F118EEA5E6!)
Diffstat (limited to 'dev-php/pecl-haru')
-rw-r--r--dev-php/pecl-haru/ChangeLog7
-rw-r--r--dev-php/pecl-haru/pecl-haru-1.0.4.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-php/pecl-haru/ChangeLog b/dev-php/pecl-haru/ChangeLog
index a40fd892699b..c2bc64aa79e9 100644
--- a/dev-php/pecl-haru/ChangeLog
+++ b/dev-php/pecl-haru/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/pecl-haru
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/ChangeLog,v 1.3 2013/03/05 11:15:20 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/ChangeLog,v 1.4 2013/12/09 21:34:18 mabi Exp $
+
+*pecl-haru-1.0.4 (09 Dec 2013)
+
+ 09 Dec 2013; Matti Bickel <mabi@gentoo.org> +pecl-haru-1.0.4.ebuild:
+ version bump, now detects haru correctly
05 Mar 2013; Ole Markus With <olemarkus@gentoo.org>
-pecl-haru-1.0.0-r1.ebuild:
diff --git a/dev-php/pecl-haru/pecl-haru-1.0.4.ebuild b/dev-php/pecl-haru/pecl-haru-1.0.4.ebuild
new file mode 100644
index 000000000000..0cba19de6fcb
--- /dev/null
+++ b/dev-php/pecl-haru/pecl-haru-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-haru/pecl-haru-1.0.4.ebuild,v 1.1 2013/12/09 21:34:18 mabi Exp $
+
+EAPI=5
+
+USE_PHP="php5-4 php5-5"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An interface to libharu, a PDF generator"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="png zlib"
+
+DEPEND="media-libs/libharu[png?,zlib?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # config.m4 is broken checking paths, so we need to override it
+ my_conf=""
+ use png && my_conf+=" --with-png-dir=/usr"
+ use zlib && my_conf+=" --with-zlib-dir=/usr"
+
+ php-ext-source-r2_src_configure
+}