summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2003-08-30 09:03:07 +0000
committerTal Peer <coredumb@gentoo.org>2003-08-30 09:03:07 +0000
commit84dfce70d0fec1937dbe11f94f40c26b316db8f7 (patch)
tree079e06b2291c484d7a2c04811d4a4b0c60295803 /dev-php/php
parentEnable embed SAPI. (diff)
downloadgentoo-2-84dfce70d0fec1937dbe11f94f40c26b316db8f7.tar.gz
gentoo-2-84dfce70d0fec1937dbe11f94f40c26b316db8f7.tar.bz2
gentoo-2-84dfce70d0fec1937dbe11f94f40c26b316db8f7.zip
Enable embed SAPI.
Diffstat (limited to 'dev-php/php')
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/Manifest4
-rw-r--r--dev-php/php/files/digest-php-5.0_beta1-r11
-rw-r--r--dev-php/php/php-5.0_beta1-r1.ebuild60
4 files changed, 69 insertions, 3 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index 8ae55becd204..5f8e10aa1074 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.57 2003/08/29 03:10:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.58 2003/08/30 09:02:58 coredumb Exp $
+
+*php-5.0_beta1-r1 (30 Aug 2003)
+ 30 Aug 2003; Tal Peer <coredumb@gentoo.org> php-5.0_beta1-r1.ebuild:
+ Enable the embed SAPI (When PHP 5.0 will be released, i will write a
+ seperate ebuild (php-embed) for this SAPI).
*php-4.3.3 (28 Aug 2003)
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 477129f100b6..d64f3e17e456 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -1,4 +1,4 @@
-MD5 e4a222b179edcb2f7e797beff8ac08fa ChangeLog 8990
+MD5 6434b9a7fa98cdc7b3d35e592704becc ChangeLog 8991
MD5 7588d047b95d706759df29bdafceb4cf php-4.3.2-r1.ebuild 992
MD5 0ad96393a56530df42b3aca284635593 php-5.0_beta1.ebuild 1179
MD5 5541cf4177bfcf205012ed0da4cd38c0 php-4.3.2.ebuild 2423
@@ -6,7 +6,7 @@ MD5 8893110f384462d0082e4171222ad880 php-4.3.2-r2.ebuild 1185
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 aa2a0765e471ace0fff21b7441c996e5 php-4.3.2-r3.ebuild 1142
MD5 ffa1b9b09eeb464e37e87bbb82d0810b php-4.3.3.ebuild 1214
-MD5 becb7c582e4078305f3e646e1d491ab5 php-5.0_beta1-r1.ebuild 1257
+MD5 2c91830acbca2b8632fa08da2b07b5d7 php-5.0_beta1-r1.ebuild 1260
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r1 137
MD5 2a7311fb659555c4711a4ed8b70e9594 files/digest-php-5.0_beta1 65
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r2 137
diff --git a/dev-php/php/files/digest-php-5.0_beta1-r1 b/dev-php/php/files/digest-php-5.0_beta1-r1
new file mode 100644
index 000000000000..3ea47d456f66
--- /dev/null
+++ b/dev-php/php/files/digest-php-5.0_beta1-r1
@@ -0,0 +1 @@
+MD5 0cb4ce9c05b639b763bc272c15fbb1a6 php-5.0.0b1.tar.bz2 3882958
diff --git a/dev-php/php/php-5.0_beta1-r1.ebuild b/dev-php/php/php-5.0_beta1-r1.ebuild
new file mode 100644
index 000000000000..83a75adf6d7b
--- /dev/null
+++ b/dev-php/php/php-5.0_beta1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-5.0_beta1-r1.ebuild,v 1.1 2003/08/30 09:02:58 coredumb Exp $
+
+PHPSAPI="cli"
+MY_P="php-5.0.0b1"
+inherit php eutils
+
+#need to override SRC_URI, the beta isn't available from the usual url which is defined in the eclass
+SRC_URI="http://us3.php.net/distributions/php-5.0.0b1.tar.bz2"
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND="${DEPEND}
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 ) "
+
+RDEPEND="${RDEPEND}"
+
+EXCLUDE_DB4_FIX=1
+EXCLUDE_PEAR_FIX=1
+
+src_compile() {
+
+ use readline && myconf="${myconf} --with-readline"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli \
+ --enable-embed"
+
+ php_src_compile
+
+}
+
+
+src_install() {
+ installtargets="${installtargets} install-cli"
+ php_src_install
+
+ #embed hack..
+ exeinto /usr/lib/
+ doexe .libs/libphp5.so
+
+ # php executable is located in ./sapi/cli/
+ exeinto /usr/bin
+ doexe sapi/cli/php
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+}
+pkg_preinst() {
+ php_pkg_preinst
+}