summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-02-08 11:40:46 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-02-08 11:40:46 +0000
commit6bf817cc1c320e07f59b87646f3e29b92594257d (patch)
treef9087ba5010fbaf6a083254b5e0fb9bd2bdb8589 /dev-php/smarty
parentApply upstream patch to fix build with as-needed and try to improve panel beh... (diff)
downloadgentoo-2-6bf817cc1c320e07f59b87646f3e29b92594257d.tar.gz
gentoo-2-6bf817cc1c320e07f59b87646f3e29b92594257d.tar.bz2
gentoo-2-6bf817cc1c320e07f59b87646f3e29b92594257d.zip
Version bump. First 3.x release of dev-php/smarty
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/ChangeLog7
-rw-r--r--dev-php/smarty/smarty-3.0.6.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
index 00b1c78b683a..feb5fc610edf 100644
--- a/dev-php/smarty/ChangeLog
+++ b/dev-php/smarty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/smarty
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.105 2011/01/06 13:10:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.106 2011/02/08 11:40:46 olemarkus Exp $
+
+*smarty-3.0.6 (04 Feb 2011)
+
+ 04 Feb 2011; Ole Markus With <olemarkus@gentoo.org> +smarty-3.0.6.ebuild:
+ Version bump. First 3.x release
06 Jan 2011; Raúl Porcel <armin76@gentoo.org> smarty-2.6.24.ebuild,
smarty-2.6.26.ebuild:
diff --git a/dev-php/smarty/smarty-3.0.6.ebuild b/dev-php/smarty/smarty-3.0.6.ebuild
new file mode 100644
index 000000000000..98e9cca69de7
--- /dev/null
+++ b/dev-php/smarty/smarty-3.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-3.0.6.ebuild,v 1.1 2011/02/08 11:40:46 olemarkus Exp $
+
+inherit php-lib-r1 eutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_P="Smarty-${PV}"
+
+DESCRIPTION="A template engine for PHP."
+HOMEPAGE="http://www.smarty.net/"
+SRC_URI="http://www.smarty.net/files/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-lang/php-5.2"
+RDEPEND="$DEPEND"
+PDEPEND="doc? ( dev-php/smarty-docs )"
+
+S="${WORKDIR}/${MY_P}"
+
+need_php_by_category
+
+src_install() {
+ dodoc-php BUGS ChangeLog FAQ NEWS QUICK_START README RELEASE_NOTES TODO
+
+ php-lib-r1_src_install ./libs `find ./libs -type f -print | sed -e "s|./libs||g"`
+}
+
+pkg_postinst() {
+ elog "${PHP_LIB_NAME} has been installed in /usr/share/php/${PHP_LIB_NAME}/."
+ elog "To use it in your scripts, either"
+ elog "1. define('SMARTY_DIR', \"/usr/share/php/${PHP_LIB_NAME}/\") in your scripts, or"
+ elog "2. add '/usr/share/php/${PHP_LIB_NAME}/' to the 'include_path' variable in your"
+ elog "php.ini file under /etc/php/SAPI (where SAPI is e.g apache2-php5.2,"
+ elog "cgi-php5.3, etc)."
+ elog
+ elog "If you're upgrading from a previous version make sure to clear out your"
+ elog "templates_c and cache directories as some include paths have changed!"
+}