summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-03-06 17:19:46 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-03-06 17:19:46 +0000
commit2e22f1746efa5cda9f1a916b93209ba729fea309 (patch)
treef92840469ab545d3fcbdf2736b92a2c5d51a0d51 /dev-php4
parentno, pkg_postinstall does not exist, so change it to pkg_postinst (diff)
downloadgentoo-2-2e22f1746efa5cda9f1a916b93209ba729fea309.tar.gz
gentoo-2-2e22f1746efa5cda9f1a916b93209ba729fea309.tar.bz2
gentoo-2-2e22f1746efa5cda9f1a916b93209ba729fea309.zip
Vbump.
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/pecl-apc/ChangeLog8
-rw-r--r--dev-php4/pecl-apc/files/digest-pecl-apc-3.0.133
-rw-r--r--dev-php4/pecl-apc/pecl-apc-3.0.12_p2.ebuild4
-rw-r--r--dev-php4/pecl-apc/pecl-apc-3.0.13.ebuild68
4 files changed, 80 insertions, 3 deletions
diff --git a/dev-php4/pecl-apc/ChangeLog b/dev-php4/pecl-apc/ChangeLog
index a07cfb100493..6be1893d9dc5 100644
--- a/dev-php4/pecl-apc/ChangeLog
+++ b/dev-php4/pecl-apc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php4/pecl-apc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/ChangeLog,v 1.20 2007/03/06 17:05:32 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/ChangeLog,v 1.21 2007/03/06 17:19:46 chtekk Exp $
+
+*pecl-apc-3.0.13 (06 Mar 2007)
+
+ 06 Mar 2007; Luca Longinotti <chtekk@gentoo.org>
+ pecl-apc-3.0.12_p2.ebuild, +pecl-apc-3.0.13.ebuild:
+ Fix apxs configure option, version bump to 3.0.13.
06 Mar 2007; Luca Longinotti <chtekk@gentoo.org>
pecl-apc-3.0.12_p2.ebuild:
diff --git a/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.13 b/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.13
new file mode 100644
index 000000000000..aa4f4fa8cd83
--- /dev/null
+++ b/dev-php4/pecl-apc/files/digest-pecl-apc-3.0.13
@@ -0,0 +1,3 @@
+MD5 69f2678bc8d4fabbfd23573e2aa32f50 APC-3.0.13.tgz 105042
+RMD160 b11aec06842d28d9870f8359338e623ded60bdd1 APC-3.0.13.tgz 105042
+SHA256 f71538b262780790bf012335d92f7dec4869454a56d3a9f9691a55e9b6071e1a APC-3.0.13.tgz 105042
diff --git a/dev-php4/pecl-apc/pecl-apc-3.0.12_p2.ebuild b/dev-php4/pecl-apc/pecl-apc-3.0.12_p2.ebuild
index 01146b43f162..465d54590f5b 100644
--- a/dev-php4/pecl-apc/pecl-apc-3.0.12_p2.ebuild
+++ b/dev-php4/pecl-apc/pecl-apc-3.0.12_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/pecl-apc-3.0.12_p2.ebuild,v 1.9 2007/03/06 17:05:32 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/pecl-apc-3.0.12_p2.ebuild,v 1.10 2007/03/06 17:19:46 chtekk Exp $
PHP_EXT_NAME="apc"
PHP_EXT_PECL_PKG="APC"
@@ -40,7 +40,7 @@ src_compile() {
my_conf="--enable-apc"
enable_extension_enable "apc-mmap" "mmap" 0
- enable_extension_with_built_with =${PHP_PKG} apache2 apxs2 /usr/sbin/apxs2 "optimisation for apache2"
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
enable_extension_with_built_with =${PHP_PKG} apache apxs /usr/sbin/apxs "optimisation for apache1"
php-ext-pecl-r1_src_compile
diff --git a/dev-php4/pecl-apc/pecl-apc-3.0.13.ebuild b/dev-php4/pecl-apc/pecl-apc-3.0.13.ebuild
new file mode 100644
index 000000000000..64263aae13b3
--- /dev/null
+++ b/dev-php4/pecl-apc/pecl-apc-3.0.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apc/pecl-apc-3.0.13.ebuild,v 1.1 2007/03/06 17:19:46 chtekk Exp $
+
+PHP_EXT_NAME="apc"
+PHP_EXT_PECL_PKG="APC"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1 confutils
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A free, open, and robust framework for caching and optimizing PHP code."
+LICENSE="PHP"
+SLOT="0"
+IUSE="mmap"
+
+DEPEND="!dev-php4/eaccelerator !dev-php4/xcache"
+RDEPEND="${DEPEND}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+ require_php_sapi_from cgi apache apache2
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-apc"
+ enable_extension_enable "apc-mmap" "mmap" 0
+ enable_extension_with_built_with =${PHP_PKG} apache2 apxs /usr/sbin/apxs2 "optimisation for apache2"
+ enable_extension_with_built_with =${PHP_PKG} apache apxs /usr/sbin/apxs "optimisation for apache1"
+
+ php-ext-pecl-r1_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r1_src_install
+ dodoc-php CHANGELOG INSTALL LICENSE NOTICE
+
+ php-ext-base-r1_addtoinifiles "apc.enabled" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_segments" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.shm_size" '"30"'
+ php-ext-base-r1_addtoinifiles "apc.optimization" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.num_files_hint" '"1024"'
+ php-ext-base-r1_addtoinifiles "apc.ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.user_ttl" '"7200"'
+ php-ext-base-r1_addtoinifiles "apc.gc_ttl" '"3600"'
+ php-ext-base-r1_addtoinifiles "apc.cache_by_default" '"1"'
+ php-ext-base-r1_addtoinifiles ";apc.mmap_file_mask" '"/tmp/apcphp4.XXXXXX"'
+ php-ext-base-r1_addtoinifiles "apc.file_update_protection" '"2"'
+ php-ext-base-r1_addtoinifiles "apc.enable_cli" '"0"'
+ php-ext-base-r1_addtoinifiles "apc.max_file_size" '"1M"'
+ php-ext-base-r1_addtoinifiles "apc.stat" '"1"'
+ php-ext-base-r1_addtoinifiles "apc.write_lock" '"1"'
+
+ dodir "${PHP_EXT_SHARED_DIR}"
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins apc.php
+}
+
+pkg_postinst() {
+ elog "The apc.php file shipped with this release of PECL-APC was"
+ elog "installed into ${ROOT}usr/share/php4/apc/."
+}