summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-11-29 23:45:16 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-11-29 23:45:16 +0000
commitbdeee8106bd6b44398db5cf32cf450331552e349 (patch)
tree05eb528e5e4ea8285ea49876146ad6dea5a7f758 /dev-php5/libchart/libchart-1.2.ebuild
parentVersion bump from project overlay (diff)
downloadgentoo-2-bdeee8106bd6b44398db5cf32cf450331552e349.tar.gz
gentoo-2-bdeee8106bd6b44398db5cf32cf450331552e349.tar.bz2
gentoo-2-bdeee8106bd6b44398db5cf32cf450331552e349.zip
Version bump from project overlay
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'dev-php5/libchart/libchart-1.2.ebuild')
-rw-r--r--dev-php5/libchart/libchart-1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php5/libchart/libchart-1.2.ebuild b/dev-php5/libchart/libchart-1.2.ebuild
new file mode 100644
index 000000000000..a11c5163ff98
--- /dev/null
+++ b/dev-php5/libchart/libchart-1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/libchart/libchart-1.2.ebuild,v 1.1 2007/11/29 23:45:15 jokey Exp $
+
+inherit php-lib-r1 depend.php
+
+DESCRIPTION="Libchart is a chart creation PHP library that is easy to use."
+HOMEPAGE="http://naku.dohcrew.com/libchart"
+SRC_URI="http://naku.dohcrew.com/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~x86"
+SLOT=0
+IUSE="examples"
+
+need_php5
+
+pkg_setup() {
+ if ! PHPCHECKNODIE="yes" require_php_with_use truetype || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with truetype and either gd or gd-external in USE."
+ fi
+}
+
+src_install() {
+ php-lib-r1_src_install ${PN} `cd ${PN}; find . -type f -print`
+ for i in ${PN}/{ChangeLog,README} ; do
+ dodoc-php ${i}
+ rm -f ${i}
+ done
+ if use examples ; then
+ insinto /usr/share/doc/${CATEGORY}/${PF}
+ doins -r demo/
+ fi
+}