summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2010-10-08 19:15:11 +0000
committerOle Markus With <olemarkus@gentoo.org>2010-10-08 19:15:11 +0000
commit4b9e5a6db2a3782be6ec9d2067862e3c266b6282 (patch)
tree044499467fd933953b5c3291dce39e0bff868715 /dev-php5
parentarm/ia64/sh stable (diff)
downloadgentoo-2-4b9e5a6db2a3782be6ec9d2067862e3c266b6282.tar.gz
gentoo-2-4b9e5a6db2a3782be6ec9d2067862e3c266b6282.tar.bz2
gentoo-2-4b9e5a6db2a3782be6ec9d2067862e3c266b6282.zip
Added version supporting minor version slotting
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/pecl-memcache/ChangeLog7
-rw-r--r--dev-php5/pecl-memcache/pecl-memcache-3.0.5-r1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-php5/pecl-memcache/ChangeLog b/dev-php5/pecl-memcache/ChangeLog
index dd13954701c5..f175b376cc6c 100644
--- a/dev-php5/pecl-memcache/ChangeLog
+++ b/dev-php5/pecl-memcache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/pecl-memcache
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.34 2010/10/04 04:59:28 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/ChangeLog,v 1.35 2010/10/08 19:15:11 olemarkus Exp $
+
+*pecl-memcache-3.0.5-r1 (08 Oct 2010)
+
+ 08 Oct 2010; <olemarkus@gentoo.org> +pecl-memcache-3.0.5-r1.ebuild:
+ Added version supporting minor version slotting
*pecl-memcache-3.0.5 (04 Oct 2010)
*pecl-memcache-2.2.6 (04 Oct 2010)
diff --git a/dev-php5/pecl-memcache/pecl-memcache-3.0.5-r1.ebuild b/dev-php5/pecl-memcache/pecl-memcache-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..55f4d0d11ebb
--- /dev/null
+++ b/dev-php5/pecl-memcache/pecl-memcache-3.0.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-memcache/pecl-memcache-3.0.5-r1.ebuild,v 1.1 2010/10/08 19:15:11 olemarkus Exp $
+
+EAPI="2"
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session"
+
+DEPEND="sys-libs/zlib
+ dev-lang/php[session?]"
+RDEPEND="${DEPEND}"
+
+# upstream does not ship any testsuite, so the PHPize test-runner fails.
+RESTRICT='test'
+
+src_compile() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
+ php-ext-pecl-r2_src_compile
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
+ php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "consistent"
+ php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
+ php-ext-source-r2_addtoinifiles "memcache.redundancy" "1"
+ php-ext-source-r2_addtoinifiles "memcache.session_redundancy" "2"
+ php-ext-source-r2_addtoinifiles "memcache.protocol" "ascii"
+}