summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-03-06 12:33:34 +0000
committerBen de Groot <yngwin@gentoo.org>2010-03-06 12:33:34 +0000
commit710d775a4b3e630eff888639ea1039470764a982 (patch)
tree01d7ff1c0b5ae50cfe1e593e898e5b3dbdcba4ad /dev-php5
parentMoved dev-util/mercurial to dev-vcs. (diff)
downloadgentoo-2-710d775a4b3e630eff888639ea1039470764a982.tar.gz
gentoo-2-710d775a4b3e630eff888639ea1039470764a982.tar.bz2
gentoo-2-710d775a4b3e630eff888639ea1039470764a982.zip
Version bump, bug #307751
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/phpunit/ChangeLog7
-rw-r--r--dev-php5/phpunit/phpunit-3.4.11.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index c1a2173346a2..1e688b25da07 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.24 2010/02/19 14:30:10 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.25 2010/03/06 12:33:34 yngwin Exp $
+
+*phpunit-3.4.11 (06 Mar 2010)
+
+ 06 Mar 2010; Ben de Groot <yngwin@gentoo.org> +phpunit-3.4.11.ebuild:
+ Version bump, bug #307751
*phpunit-3.3.1-r1 (19 Feb 2010)
diff --git a/dev-php5/phpunit/phpunit-3.4.11.ebuild b/dev-php5/phpunit/phpunit-3.4.11.ebuild
new file mode 100644
index 000000000000..1e7717a8547a
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.4.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.4.11.ebuild,v 1.1 2010/03/06 12:33:34 yngwin Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="minimal"
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}
+ !minimal? ( >=dev-php5/xdebug-2.0.5
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ require_php_with_use pcre reflection simplexml spl xml tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+}