summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-06-12 17:39:19 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-06-12 17:39:19 +0000
commit798ee50479430fa750405fd3959b0fa52704acec (patch)
tree5873a1b966ebd175dc7c2adb6fad57969d67b4c9 /dev-php5
parentFix SRC_URI for x86 shared-qt. (diff)
downloadgentoo-2-798ee50479430fa750405fd3959b0fa52704acec.tar.gz
gentoo-2-798ee50479430fa750405fd3959b0fa52704acec.tar.bz2
gentoo-2-798ee50479430fa750405fd3959b0fa52704acec.zip
updated patch by Martin von Gagern <Martin.vGagern@gmx.net> (bug 215671), previous version missed some MagickWand-config calls. magickwand-1.0.7 should now really build with <imagemagick-6.3.8
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/magickwand/ChangeLog8
-rw-r--r--dev-php5/magickwand/files/imagemagick-pre-6.3.8-compat.patch39
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-php5/magickwand/ChangeLog b/dev-php5/magickwand/ChangeLog
index 32780c586ea9..91cbc22adbfd 100644
--- a/dev-php5/magickwand/ChangeLog
+++ b/dev-php5/magickwand/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/magickwand
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/magickwand/ChangeLog,v 1.8 2008/06/09 15:33:53 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/magickwand/ChangeLog,v 1.9 2008/06/12 17:39:18 hoffie Exp $
+
+ 12 Jun 2008; Christian Hoffmann <hoffie@gentoo.org>
+ files/imagemagick-pre-6.3.8-compat.patch:
+ updated patch by Martin von Gagern <Martin.vGagern@gmx.net> (bug 215671),
+ previous version missed some MagickWand-config calls. magickwand-1.0.7
+ should now really build with <imagemagick-6.3.8
09 Jun 2008; Christian Hoffmann <hoffie@gentoo.org>
+files/imagemagick-pre-6.3.8-compat.patch, magickwand-1.0.7.ebuild:
diff --git a/dev-php5/magickwand/files/imagemagick-pre-6.3.8-compat.patch b/dev-php5/magickwand/files/imagemagick-pre-6.3.8-compat.patch
index 86679b72b180..b8634304ed15 100644
--- a/dev-php5/magickwand/files/imagemagick-pre-6.3.8-compat.patch
+++ b/dev-php5/magickwand/files/imagemagick-pre-6.3.8-compat.patch
@@ -2,7 +2,44 @@
# patch by Martin von Gagern <Martin.vGagern@gmx.net>
--- MagickWandForPHP-1.0.7-1/config.m4 2008-04-13 19:30:55.000000000 +0200
-+++ MagickWandForPHP-1.0.7/config.m4 2008-06-09 17:08:03.000000000 +0200
++++ MagickWandForPHP-1.0.7/config.m4 2008-06-10 11:34:24.000000000 +0200
+@@ -3,30 +3,30 @@
+
+ if test $PHP_MAGICKWAND != "no"; then
+
+- if test -r $PHP_MAGICKWAND/bin/MagickWand-config; then
++ if test -r $PHP_MAGICKWAND/bin/Wand-config; then
+ WAND_CONFIG_PATH=$PHP_MAGICKWAND/bin
+ else
+- AC_MSG_CHECKING(MagickWand-config in default path)
++ AC_MSG_CHECKING(Wand-config in default path)
+
+ for i in /usr/local /usr;
+ do
+- test -r $i/bin/MagickWand-config && WAND_CONFIG_PATH=$i/bin && break
++ test -r $i/bin/Wand-config && WAND_CONFIG_PATH=$i/bin && break
+ done
+
+ if test -z "$WAND_CONFIG_PATH"; then
+ for i in $PHP_MAGICKWAND /usr/local /usr;
+ do
+- test -r $i/MagickWand-config && WAND_CONFIG_PATH=$i && break
++ test -r $i/Wand-config && WAND_CONFIG_PATH=$i && break
+ done
+ fi
+ if test -z "$WAND_CONFIG_PATH"; then
+- AC_MSG_ERROR(Cannot locate configuration program MagickWand-config)
++ AC_MSG_ERROR(Cannot locate configuration program Wand-config)
+ else
+ AC_MSG_RESULT(found in $WAND_CONFIG_PATH)
+ fi
+ fi
+
+- IMAGEMAGICK_VERSION_ORIG=`$WAND_CONFIG_PATH/MagickWand-config --version`
++ IMAGEMAGICK_VERSION_ORIG=`$WAND_CONFIG_PATH/Wand-config --version`
+ IMAGEMAGICK_VERSION_MASK=`echo ${IMAGEMAGICK_VERSION_ORIG} | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+
+
@@ -34,7 +34,7 @@
if test "$IMAGEMAGICK_VERSION_MASK" -ge 6003005; then
AC_MSG_RESULT(found version $IMAGEMAGICK_VERSION_ORIG)