summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-09-13 10:20:21 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-09-13 10:20:21 +0000
commitb7563b4faebac4202b7bf0a19afe0ab575a1d8b7 (patch)
tree06f7f974c2b98a5c36e2caa88a3c12bae6cc1d9e /dev-php5
parentVersion bump, remove old. (diff)
downloadgentoo-2-b7563b4faebac4202b7bf0a19afe0ab575a1d8b7.tar.gz
gentoo-2-b7563b4faebac4202b7bf0a19afe0ab575a1d8b7.tar.bz2
gentoo-2-b7563b4faebac4202b7bf0a19afe0ab575a1d8b7.zip
Re-add gtkhtml support, thanks to Yaakov S. suggested patch, bug #280961.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/php-gtk/ChangeLog8
-rw-r--r--dev-php5/php-gtk/files/php-gtk-2.0.1-gtkhtml314.patch32
-rw-r--r--dev-php5/php-gtk/php-gtk-2.0.1-r1.ebuild126
3 files changed, 165 insertions, 1 deletions
diff --git a/dev-php5/php-gtk/ChangeLog b/dev-php5/php-gtk/ChangeLog
index 845ea7042133..4e37e8894a7d 100644
--- a/dev-php5/php-gtk/ChangeLog
+++ b/dev-php5/php-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/php-gtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-gtk/ChangeLog,v 1.16 2009/09/12 21:35:59 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-gtk/ChangeLog,v 1.17 2009/09/13 10:20:21 eva Exp $
+
+*php-gtk-2.0.1-r1 (13 Sep 2009)
+
+ 13 Sep 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +php-gtk-2.0.1-r1.ebuild, +files/php-gtk-2.0.1-gtkhtml314.patch:
+ Re-add gtkhtml support, thanks to Yaakov S. suggested patch, bug #280961.
12 Sep 2009; Gilles Dartiguelongue <eva@gentoo.org> php-gtk-2.0.0.ebuild,
php-gtk-2.0.1.ebuild, metadata.xml:
diff --git a/dev-php5/php-gtk/files/php-gtk-2.0.1-gtkhtml314.patch b/dev-php5/php-gtk/files/php-gtk-2.0.1-gtkhtml314.patch
new file mode 100644
index 000000000000..c14526121b68
--- /dev/null
+++ b/dev-php5/php-gtk/files/php-gtk-2.0.1-gtkhtml314.patch
@@ -0,0 +1,32 @@
+--- a/ext/html/html.defs 2008-08-17 16:40:39.000000000 +0200
++++ b/ext/html/html.defs 2008-08-17 16:41:10.000000000 +0200
+@@ -103,18 +103,6 @@
+ (return-type "none")
+ )
+
+-(define-method request_paste
+- (of-object "GtkHTML")
+- (c-name "gtk_html_request_paste")
+- (return-type "int")
+- (parameters
+- '("GdkAtom" "selection")
+- '("gint" "type")
+- '("gint32" "time")
+- '("gboolean" "as_cite")
+- )
+-)
+-
+ (define-method begin
+ (of-object "GtkHTML")
+ (c-name "gtk_html_begin")
+--- a/ext/html/config.m4 2008-08-17 16:44:57.000000000 +0200
++++ b/ext/html/config.m4 2008-08-17 16:45:05.000000000 +0200
+@@ -7,7 +7,7 @@
+ [ --with-html Enable GtkHtml support],no)
+
+ if test "$PHP_GTK_HTML" != "no"; then
+- PKG_CHECK_MODULES(HTML, [libgtkhtml-3.8 >= html_required_version],
++ PKG_CHECK_MODULES(HTML, [libgtkhtml-3.14 >= html_required_version],
+ have_html=yes, have_html=no)
+ if test "$have_html" != "yes"; then
+ AC_MSG_RESULT([Unable to locate libgtkhtml version html_required_version or higher: not building])
diff --git a/dev-php5/php-gtk/php-gtk-2.0.1-r1.ebuild b/dev-php5/php-gtk/php-gtk-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..c3d028ec582a
--- /dev/null
+++ b/dev-php5/php-gtk/php-gtk-2.0.1-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-gtk/php-gtk-2.0.1-r1.ebuild,v 1.1 2009/09/13 10:20:21 eva Exp $
+
+EAPI="1"
+
+PHP_EXT_NAME="php_gtk2"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHPSAPILIST="cli"
+DOCS="AUTHORS ChangeLog INSTALL NEWS README README.KNOWN-ISSUES TODO2"
+
+inherit php-ext-source-r1
+
+DESCRIPTION="PHP 5 bindings for the Gtk+ 2 library."
+HOMEPAGE="http://gtk.php.net/"
+SRC_URI="http://gtk.php.net/distributions/${P}.tar.gz"
+IUSE="debug doc examples extra +glade gtkhtml libsexy mozembed scintilla spell"
+LICENSE="PHP-2.02 PHP-3 PHP-3.01 LGPL-2.1 public-domain Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MYDOC_PN="php_gtk_manual"
+MYDOC_PV="20071130"
+
+LANGS="bg en ja pt_BR zh_CN"
+for lang in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${lang}"
+ SRC_URI="${SRC_URI}
+ doc? ( linguas_${lang}? ( http://dev.gentooexperimental.org/~jakub/distfiles/${MYDOC_PN}-${MYDOC_PV}_${lang}.tar.bz2
+ mirror://gentoo/${MYDOC_PN}-${MYDOC_PV}_${lang}.tar.bz2 ) )"
+done
+
+RDEPEND=">=dev-lang/php-5.1.2
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/pango-1.8.0
+ >=dev-libs/atk-1.9.0
+ extra? ( >=x11-libs/gtk+extra-2.1.1 )
+ glade? ( >=gnome-base/libglade-2.5.0 )
+ libsexy? ( >=x11-libs/libsexy-0.1.10 )
+ gtkhtml? ( gnome-extra/gtkhtml:3.14 )
+ mozembed? ( >=www-client/mozilla-firefox-1.5.0 )
+ spell? ( >=app-text/gtkspell-2.0.0 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ if use debug ; then
+ require_php_with_use cli pcre debug
+ else
+ if has_debug ; then
+ # PHP has debug enabled, but PHP-GTK doesn't!
+ eerror "Please enable the 'debug' USE flag in PHP-GTK."
+ eerror "This is needed to work with the debug version of PHP."
+ die "Enable 'debug' USE flag for dev-lang/php"
+ fi
+ require_php_with_use cli pcre
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd "${S}"
+ # we already check for CLI and built-in check creates trouble
+ # on suhosin-based installations, so we remove it
+ epatch "${FILESDIR}"/${PN}-2.0.0-no-cli-check.patch
+
+ # depends on newer gtkhtml
+ epatch "${FILESDIR}"/${PN}-2.0.1-gtkhtml314.patch
+
+ # see bug 232538 for details:
+ # this is needed so that autoconf can find the m4 gtk files (non-standard
+ # location)
+ export AT_M4DIR="${S}"
+ # phpize will invoke autoconf/autoheader (which will fail); we are replacing
+ # these calls with dummies as we call eautoreconf shortly afterwards
+ # anyway
+ export PHP_AUTOCONF="true"
+ export PHP_AUTOHEADER="true"
+ php-ext-source-r1_phpize
+
+ cd "${WORKDIR}"
+ for lang in ${LANGS} ; do
+ if use doc && use linguas_${lang} ; then
+ mkdir ${lang}
+ pushd ${lang} >/dev/null
+ unpack ${MYDOC_PN}-${MYDOC_PV}_${lang}.tar.bz2
+ popd >/dev/null
+ fi
+ done
+}
+
+src_compile() {
+ my_conf="$(use_with extra) \
+ $(use_with gtkhtml html) \
+ $(use_with libsexy) \
+ $(use_with mozembed) \
+ $(use_with spell) \
+ $(use_enable debug) \
+ $(use_enable scintilla) \
+ --without-sourceview \
+ $(use glade || echo '--without-libglade')"
+ php-ext-source-r1_src_compile
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+
+ if use doc; then
+ for lang in ${LANGS} ; do
+ if use linguas_${lang} ; then
+ ebegin "Installing ${lang} manual, will take a while"
+ insinto /usr/share/doc/${CATEGORY}/${PF}/manual-${lang}
+ doins -r "${WORKDIR}"/${lang}/html/*
+ eend $?
+ fi
+ done
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${CATEGORY}/${PF}/examples
+ doins -r "${S}"/demos/*
+ fi
+}