summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-05-28 19:01:46 +0000
committerAnant Narayanan <anant@gentoo.org>2007-05-28 19:01:46 +0000
commitfc1c1bb342b009253c47f86970619a43e9b07b7e (patch)
treee2c059a83239a8f6c2e5fba743b7e725a195927a /dev-php5
parentfixed mirror:// in SRC_URI (diff)
downloadgentoo-2-fc1c1bb342b009253c47f86970619a43e9b07b7e.tar.gz
gentoo-2-fc1c1bb342b009253c47f86970619a43e9b07b7e.tar.bz2
gentoo-2-fc1c1bb342b009253c47f86970619a43e9b07b7e.zip
vBump to 2.15.5
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/phpdbg/ChangeLog7
-rw-r--r--dev-php5/phpdbg/files/digest-phpdbg-2.15.53
-rw-r--r--dev-php5/phpdbg/phpdbg-2.15.5.ebuild52
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-php5/phpdbg/ChangeLog b/dev-php5/phpdbg/ChangeLog
index 07820e96f923..1c7d4551f251 100644
--- a/dev-php5/phpdbg/ChangeLog
+++ b/dev-php5/phpdbg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phpdbg
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.9 2007/03/18 01:26:12 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/ChangeLog,v 1.10 2007/05/28 19:01:46 anant Exp $
+
+*phpdbg-2.15.5 (28 May 2007)
+
+ 28 May 2007; Anant Narayanan <anant@gentoo.org> +phpdbg-2.15.5.ebuild:
+ vBump to 2.15.5
18 Mar 2007; Luca Longinotti <chtekk@gentoo.org> phpdbg-2.15.1.ebuild:
Cleanup.
diff --git a/dev-php5/phpdbg/files/digest-phpdbg-2.15.5 b/dev-php5/phpdbg/files/digest-phpdbg-2.15.5
new file mode 100644
index 000000000000..d7205fff5e63
--- /dev/null
+++ b/dev-php5/phpdbg/files/digest-phpdbg-2.15.5
@@ -0,0 +1,3 @@
+MD5 1183c5d87635adf77b416787e4916965 dbg-2.15.5.tar.gz 252533
+RMD160 396e9658ffa4adc3b3669a7185f79444264cd932 dbg-2.15.5.tar.gz 252533
+SHA256 84dc46495610cd6ca96ff32578ee5df75aad672228cb63d593e72796bd11d77a dbg-2.15.5.tar.gz 252533
diff --git a/dev-php5/phpdbg/phpdbg-2.15.5.ebuild b/dev-php5/phpdbg/phpdbg-2.15.5.ebuild
new file mode 100644
index 000000000000..e7e0c9c631c8
--- /dev/null
+++ b/dev-php5/phpdbg/phpdbg-2.15.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpdbg/phpdbg-2.15.5.ebuild,v 1.1 2007/05/28 19:01:46 anant Exp $
+
+PHP_EXT_NAME="dbg"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="A PHP debugger useable with some editors like phpedit."
+HOMEPAGE="http://dd.cron.ru/dbg/"
+SRC_URI="mirror://sourceforge/dbg2/dbg-${PV}.tar.gz"
+LICENSE="dbgphp"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/dbg-${PV}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ # phpdbg does not work with Zend Thread Safety (ZTS),
+ # so abort if we're using PHP compiled with ZTS.
+ if has_zts ; then
+ eerror "phpdbg doesn't work with a ZTS enabled PHP."
+ eerror "Please disable ZTS by turning the 'threads'"
+ eerror "USE flag off when you compile dev-lang/php."
+ die "phpdbg does not support ZTS"
+ fi
+}
+
+src_compile() {
+ my_conf="--enable-dbg=shared --with-dbg-profiler"
+ php-ext-source-r1_src_compile
+}
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php AUTHORS COPYING INSTALL
+
+ php-ext-base-r1_addtoinifiles "[Debugger]"
+ php-ext-base-r1_addtoinifiles "debugger.enabled" "on"
+ php-ext-base-r1_addtoinifiles "debugger.profiler_enabled" "on"
+}