summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2012-04-07 21:23:11 +0000
committerOle Markus With <olemarkus@gentoo.org>2012-04-07 21:23:11 +0000
commit0ee115453f5e04008d6e6c5903ae4b950a02f03f (patch)
tree48c9071bcd9c88d5fb876022510e947b1bb095a3 /dev-php
parentRemove old. (diff)
downloadgentoo-2-0ee115453f5e04008d6e6c5903ae4b950a02f03f.tar.gz
gentoo-2-0ee115453f5e04008d6e6c5903ae4b950a02f03f.tar.bz2
gentoo-2-0ee115453f5e04008d6e6c5903ae4b950a02f03f.zip
Version bump. RC that works with php 5.4
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-client/ChangeLog8
-rw-r--r--dev-php/xdebug-client/xdebug-client-2.2.0_rc1.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-php/xdebug-client/ChangeLog b/dev-php/xdebug-client/ChangeLog
index ce11109ac004..a3c89c8de2fa 100644
--- a/dev-php/xdebug-client/ChangeLog
+++ b/dev-php/xdebug-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/xdebug-client
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.37 2012/03/13 13:21:06 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/ChangeLog,v 1.38 2012/04/07 21:23:11 olemarkus Exp $
+
+*xdebug-client-2.2.0_rc1 (07 Apr 2012)
+
+ 07 Apr 2012; Ole Markus With <olemarkus@gentoo.org>
+ +xdebug-client-2.2.0_rc1.ebuild:
+ Version bump. RC that works with php 5.4
*xdebug-client-2.1.4 (13 Mar 2012)
diff --git a/dev-php/xdebug-client/xdebug-client-2.2.0_rc1.ebuild b/dev-php/xdebug-client/xdebug-client-2.2.0_rc1.ebuild
new file mode 100644
index 000000000000..52626bb7d350
--- /dev/null
+++ b/dev-php/xdebug-client/xdebug-client-2.2.0_rc1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug-client/xdebug-client-2.2.0_rc1.ebuild,v 1.1 2012/04/07 21:23:11 olemarkus Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE="libedit"
+
+S="${WORKDIR}/xdebug-${MY_PV}/debugclient"
+
+DEPEND="libedit? ( dev-libs/libedit )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ chmod +x "${S}"/configure
+}
+
+src_compile() {
+ econf $(use_with libedit) --disable-dependency-tracking
+ emake || die "Build of debug client failed!"
+}
+
+src_install() {
+ newbin debugclient xdebug
+}