summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-12 10:46:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-12 10:46:06 +0000
commit4d7dd88ea0a78b5ba5920c35d577b723124d295b (patch)
treec74fa030dce700fcbc5e81e8e9bae5b094b60837 /dev-php
parentget_name() scans past the first ':' looking for <digit>*: - however if the by... (diff)
downloadgentoo-2-4d7dd88ea0a78b5ba5920c35d577b723124d295b.tar.gz
gentoo-2-4d7dd88ea0a78b5ba5920c35d577b723124d295b.tar.bz2
gentoo-2-4d7dd88ea0a78b5ba5920c35d577b723124d295b.zip
Roll out 4.3.9rc1 in ~arch, to fix 4.3.8 problems.
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/php/ChangeLog7
-rw-r--r--dev-php/php/Manifest2
-rw-r--r--dev-php/php/files/digest-php-4.3.9_rc12
-rw-r--r--dev-php/php/php-4.3.9_rc1.ebuild45
4 files changed, 55 insertions, 1 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index de09dac5f479..12a55aade3bd 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/php
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.113 2004/08/09 09:50:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.114 2004/08/12 10:46:06 robbat2 Exp $
+
+*php-4.3.9_rc1 (12 Aug 2004)
+
+ 12 Aug 2004; Robin H. Johnson <robbat2@gentoo.org> +php-4.3.9_rc1.ebuild:
+ Roll out 4.3.9rc1 in ~arch, to fix 4.3.8 problems.
09 Aug 2004; Robin H. Johnson <robbat2@gentoo.org> php-5.0.0-r1.ebuild:
Enable embedded API.
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 4e9be077a413..4cd0235bccc9 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -1,9 +1,11 @@
MD5 48aa6f4b37fb2c3cc4fa6ad0527f4378 php-5.0.0.ebuild 521
+MD5 34d45af62c3298c13df9e6f3529174de php-4.3.9_rc1.ebuild 1120
MD5 53c61d1adf84089156f9543142d728bc ChangeLog 16504
MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 e6155fb0a46e8d230ef0472314e3d3e6 php-5.0.0-r1.ebuild 540
MD5 187ba72438d0a6f430dde8b3ae1063a9 php-4.3.8.ebuild 1067
MD5 7515e9b1dc298a0fb1c12d35a58c265d files/php-4.3.4-amd64hack.diff 1028
+MD5 3d9b5ebf0a273b87c7a9355fa0d0676d files/digest-php-4.3.9_rc1 134
MD5 cd07c33356df77acd61cd300f2869d19 files/php-5.0.0-httpauthfix.patch 518
MD5 11f305b98b753ee023da8503a360762a files/digest-php-5.0.0-r1 63
MD5 273799e60d5a41a1e6f5ac53781a152f files/php5_soap_persistence_session.diff 1976
diff --git a/dev-php/php/files/digest-php-4.3.9_rc1 b/dev-php/php/files/digest-php-4.3.9_rc1
new file mode 100644
index 000000000000..8de3f0580d5a
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.9_rc1
@@ -0,0 +1,2 @@
+MD5 b741b28a55ae1b2b12ca53f590ac9f99 php-4.3.9RC1.tar.bz2 4000405
+MD5 fbb6b365f4c0263b1dfd498aef092a77 php-4.3.6-includepath.diff 285
diff --git a/dev-php/php/php-4.3.9_rc1.ebuild b/dev-php/php/php-4.3.9_rc1.ebuild
new file mode 100644
index 000000000000..a9ad42f78265
--- /dev/null
+++ b/dev-php/php/php-4.3.9_rc1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.9_rc1.ebuild,v 1.1 2004/08/12 10:46:06 robbat2 Exp $
+
+PHPSAPI="cli"
+SRC_URI_BASE="http://downloads.php.net/ilia/" # for RC only
+inherit php-sapi eutils
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~s390"
+IUSE=""
+
+src_unpack() {
+ php-sapi_src_unpack
+ [ "${ARCH}" == "amd64" ] && epatch ${FILESDIR}/php-4.3.4-amd64hack.diff
+}
+
+src_compile() {
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php-sapi_src_compile
+}
+
+
+src_install() {
+ PHP_INSTALLTARGETS="install"
+ php-sapi_src_install
+
+ einfo "Installing manpage"
+ doman sapi/cli/php.1
+}
+
+pkg_postinst() {
+ php-sapi_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You cannot use it on a webserver."
+
+ if [ -f "${ROOT}/root/.pearrc" -a "`md5sum ${ROOT}/root/.pearrc`" = "f0243f51b2457bc545158cf066e4e7a2 ${ROOT}/root/.pearrc" ]; then
+ einfo "Cleaning up an old PEAR install glitch"
+ mv ${ROOT}/root/.pearrc ${ROOT}/root/.pearrc.`date +%Y%m%d%H%M%S`
+ fi
+}