summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-25 10:00:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-25 10:00:50 +0000
commitb2ff7b27747b057df55768088944a03e524615bc (patch)
tree464b5ee63db7702e241ac6925736285223d129fe /dev-php
parentDrop old, adjust mupdf dependency (diff)
downloadgentoo-2-b2ff7b27747b057df55768088944a03e524615bc.tar.gz
gentoo-2-b2ff7b27747b057df55768088944a03e524615bc.tar.bz2
gentoo-2-b2ff7b27747b057df55768088944a03e524615bc.zip
Fix build and runtime with ffmpeg-1. Bug #461438
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/ffmpeg-php/ChangeLog7
-rw-r--r--dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r2.ebuild4
-rw-r--r--dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffincludes.patch115
-rw-r--r--dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg1.patch30
4 files changed, 154 insertions, 2 deletions
diff --git a/dev-php/ffmpeg-php/ChangeLog b/dev-php/ffmpeg-php/ChangeLog
index ce1fd1300927..3aaf6f892f8a 100644
--- a/dev-php/ffmpeg-php/ChangeLog
+++ b/dev-php/ffmpeg-php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/ffmpeg-php
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ChangeLog,v 1.5 2013/03/05 10:41:09 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ChangeLog,v 1.6 2013/03/25 10:00:50 aballier Exp $
+
+ 25 Mar 2013; Alexis Ballier <aballier@gentoo.org> ffmpeg-php-0.6.0-r2.ebuild,
+ +files/ffmpeg-php-0.6.0-ffincludes.patch,
+ +files/ffmpeg-php-0.6.0-ffmpeg1.patch:
+ Fix build and runtime with ffmpeg-1. Bug #461438
05 Mar 2013; Ole Markus With <olemarkus@gentoo.org>
ffmpeg-php-0.6.0-r1.ebuild, ffmpeg-php-0.6.0-r2.ebuild:
diff --git a/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r2.ebuild b/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r2.ebuild
index 77fe0153c17d..2c6b61b48314 100644
--- a/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r2.ebuild
+++ b/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r2.ebuild,v 1.2 2013/03/05 10:41:09 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r2.ebuild,v 1.3 2013/03/25 10:00:50 aballier Exp $
EAPI="5"
@@ -39,6 +39,8 @@ src_prepare() {
epatch "${FILESDIR}/${P}-ffmpeg.patch"
epatch "${FILESDIR}/${P}-log.patch"
epatch "${FILESDIR}/${P}-php5-4.patch"
+ epatch "${FILESDIR}/${P}-ffincludes.patch"
+ epatch "${FILESDIR}/${P}-ffmpeg1.patch"
done
php-ext-source-r2_src_prepare
}
diff --git a/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffincludes.patch b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffincludes.patch
new file mode 100644
index 000000000000..5b7873ece51b
--- /dev/null
+++ b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffincludes.patch
@@ -0,0 +1,115 @@
+Incldue properly FFmpeg headers.
+https://bugs.gentoo.org/show_bug.cgi?id=461438
+
+Index: php5.3/config.m4
+===================================================================
+--- php5.3.orig/config.m4
++++ php5.3/config.m4
+@@ -31,15 +31,8 @@ if test "$PHP_FFMPEG" != "no"; then
+ FFMPEG_INC_FOUND=$i/include
+ break
+ elif test -f $i/include/libavcodec/avcodec.h; then
+- dnl ffmpeg svn revision 12194 and newer put each header in its own dir
+- dnl so we have to include them all.
+- PHP_ADD_INCLUDE($i/include/libavcodec/)
+- PHP_ADD_INCLUDE($i/include/libavformat/)
+- PHP_ADD_INCLUDE($i/include/libavutil/)
+- PHP_ADD_INCLUDE($i/include/libswscale/)
+- PHP_ADD_INCLUDE($i/include/libavfilter/)
+- PHP_ADD_INCLUDE($i/include/libavdevice/)
+- FFMPEG_INC_FOUND=$i/include/libavcodec
++ PHP_ADD_INCLUDE($i/include)
++ FFMPEG_INC_FOUND=$i/include
+ break
+ fi
+ done
+Index: php5.3/ffmpeg-php.c
+===================================================================
+--- php5.3.orig/ffmpeg-php.c
++++ php5.3/ffmpeg-php.c
+@@ -39,11 +39,11 @@
+
+ #include "php.h"
+
+-#include <avcodec.h>
+-#include <avformat.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
+
+ #if HAVE_SWSCALER
+-#include <swscale.h>
++#include <libswscale/swscale.h>
+ #endif
+
+ #include "php_ini.h"
+Index: php5.3/ffmpeg_errorhandler.c
+===================================================================
+--- php5.3.orig/ffmpeg_errorhandler.c
++++ php5.3/ffmpeg_errorhandler.c
+@@ -34,7 +34,7 @@
+ */
+
+ #include "php.h"
+-#include <avcodec.h>
++#include <libavcodec/avcodec.h>
+
+ /* {{{ ffmpeg_errorhandler()
+ */
+Index: php5.3/ffmpeg_frame.h
+===================================================================
+--- php5.3.orig/ffmpeg_frame.h
++++ php5.3/ffmpeg_frame.h
+@@ -38,8 +38,8 @@
+
+ #include "php_version.h"
+
+-#include <avcodec.h>
+-#include <avformat.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+Index: php5.3/ffmpeg_movie.c
+===================================================================
+--- php5.3.orig/ffmpeg_movie.c
++++ php5.3/ffmpeg_movie.c
+@@ -34,9 +34,9 @@
+ #include "php_globals.h"
+ #include "ext/standard/info.h"
+
+-#include <avcodec.h>
+-#include <avformat.h>
+-#include <pixdesc.h>
++#include <libavcodec/avcodec.h>
++#include <libavformat/avformat.h>
++#include <libavutil/pixdesc.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include "config.h"
+Index: php5.3/ffmpeg_tools.c
+===================================================================
+--- php5.3.orig/ffmpeg_tools.c
++++ php5.3/ffmpeg_tools.c
+@@ -42,7 +42,7 @@
+ #include "ffmpeg_tools.h"
+
+ #ifdef HAVE_SWSCALER
+-#include <swscale.h>
++#include <libswscale/swscale.h>
+ #endif
+
+ /* {{{ ffmpeg_img_convert()
+Index: php5.3/ffmpeg_tools.h
+===================================================================
+--- php5.3.orig/ffmpeg_tools.h
++++ php5.3/ffmpeg_tools.h
+@@ -36,7 +36,7 @@
+ #ifndef FFMPEG_TOOLS_H
+ #define FFMPEG_TOOLS_H
+
+-#include <avcodec.h>
++#include <libavcodec/avcodec.h>
+
+ int ffmpeg_img_convert(
+ AVPicture *dst, int dst_pix_fmt,
diff --git a/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg1.patch b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg1.patch
new file mode 100644
index 000000000000..a66d92b04f51
--- /dev/null
+++ b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg1.patch
@@ -0,0 +1,30 @@
+Fix runtime with ffmpeg-1.
+https://bugs.gentoo.org/show_bug.cgi?id=461438
+
+Index: php5.3/ffmpeg-php.c
+===================================================================
+--- php5.3.orig/ffmpeg-php.c
++++ php5.3/ffmpeg-php.c
+@@ -90,9 +90,6 @@ PHP_INI_END()
+ */
+ PHP_MINIT_FUNCTION(ffmpeg)
+ {
+- /* must be called before using avcodec libraries. */
+- avcodec_init();
+-
+ /* register all codecs */
+ av_register_all();
+
+Index: php5.3/ffmpeg_movie.c
+===================================================================
+--- php5.3.orig/ffmpeg_movie.c
++++ php5.3/ffmpeg_movie.c
+@@ -259,7 +259,7 @@ static int _php_open_movie_file(ff_movie
+ }
+
+ /* open the file with generic libav function */
+- if (av_open_input_file(&ffmovie_ctx->fmt_ctx, filename, NULL, 0, NULL) < 0) {
++ if (avformat_open_input(&ffmovie_ctx->fmt_ctx, filename, NULL, NULL) < 0) {
+ return 1;
+ }
+