summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-07-30 10:00:16 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-07-30 10:00:16 +0000
commite92ad2a7922844f4de67bf1660eb3fa5a16a96ab (patch)
tree3633fc1864be5206f2e7633b3d5d471b8147dc5e /dev-php
parentRequire newer boost and completely disable lua support for now. (diff)
downloadgentoo-2-e92ad2a7922844f4de67bf1660eb3fa5a16a96ab.tar.gz
gentoo-2-e92ad2a7922844f4de67bf1660eb3fa5a16a96ab.tar.bz2
gentoo-2-e92ad2a7922844f4de67bf1660eb3fa5a16a96ab.zip
Version bump. Bug 376991
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpunit/ChangeLog7
-rw-r--r--dev-php/phpunit/phpunit-3.5.14.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-php/phpunit/ChangeLog b/dev-php/phpunit/ChangeLog
index 723590e870fc..80886cf41827 100644
--- a/dev-php/phpunit/ChangeLog
+++ b/dev-php/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/phpunit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.4 2011/05/24 14:55:40 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/ChangeLog,v 1.5 2011/07/30 10:00:16 olemarkus Exp $
+
+*phpunit-3.5.14 (30 Jul 2011)
+
+ 30 Jul 2011; <olemarkus@gentoo.org> +phpunit-3.5.14.ebuild:
+ Version bump. Bug 376991
24 May 2011; Markos Chandras <hwoarang@gentoo.org> phpunit-3.5.13.ebuild:
Stable on amd64 wrt bug #368293
diff --git a/dev-php/phpunit/phpunit-3.5.14.ebuild b/dev-php/phpunit/phpunit-3.5.14.ebuild
new file mode 100644
index 000000000000..f059317e990f
--- /dev/null
+++ b/dev-php/phpunit/phpunit-3.5.14.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpunit/phpunit-3.5.14.ebuild,v 1.1 2011/07/30 10:00:16 olemarkus Exp $
+
+EAPI="2"
+PHP_PEAR_CHANNEL="${FILESDIR}/channel.xml"
+PHP_PEAR_PN="PHPUnit"
+
+PHP_PEAR_URI="pear.phpunit.de"
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.2.7[simplexml,xml,tokenizer]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/dbunit-1.0.0
+ >=dev-php5/PEAR-Text_Template-1.0.0
+ >=dev-php/php-codecoverage-1.0.2
+ >=dev-php/php-timer-1.0.0
+ >=dev-php5/phpunit-mockobject-1.0.3
+ >=dev-php5/phpunit-selenium-1.0.1
+ >=dev-php/file-iterator-1.2.3
+ >=dev-php/yaml-1.0.2"
+
+pkg_postinst() {
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge dev-lang/php with USE=\"json pdo sqlite mysql\"."
+}