summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-03-18 01:44:51 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-03-18 01:44:51 +0000
commit9a9731cc9036ea0dd04f21b7684060316cbcffac (patch)
treedc02ad6c409584aa2326c3c6b3e9d1d4507ef28e /dev-python/PyQt/PyQt-3.11.ebuild
parentlatest 3.10 version - bugfixes (Manifest recommit) (diff)
downloadgentoo-2-9a9731cc9036ea0dd04f21b7684060316cbcffac.tar.gz
gentoo-2-9a9731cc9036ea0dd04f21b7684060316cbcffac.tar.bz2
gentoo-2-9a9731cc9036ea0dd04f21b7684060316cbcffac.zip
New bugfix version
Diffstat (limited to 'dev-python/PyQt/PyQt-3.11.ebuild')
-rw-r--r--dev-python/PyQt/PyQt-3.11.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/PyQt/PyQt-3.11.ebuild b/dev-python/PyQt/PyQt-3.11.ebuild
new file mode 100644
index 000000000000..f05a50509d2b
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.11.ebuild,v 1.1 2004/03/18 01:44:51 caleb Exp $
+
+inherit distutils
+
+IUSE=""
+MY_P="PyQt-x11-gpl-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/${MY_P}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ x11-libs/qt
+ dev-lang/python
+ >=dev-python/sip-3.10.1
+ >=dev-python/qscintilla-1.54"
+
+src_compile() {
+ distutils_python_version
+
+ # standard qt sandbox problem workaround
+ [ -d "$QTDIR/etc/settings" ] && addwrite "$QTDIR/etc/settings"
+ dodir /usr/lib/python${PYVER}/site-packages /usr/include/python${PYVER} /usr/bin /usr/share/sip
+ cd ${S}
+ sed -i -e "s/ check_license()/# check_license()/" configure.py
+ python configure.py \
+ -d ${D}usr/lib/python${PYVER}/site-packages \
+ -b ${D}usr/bin \
+ -v ${D}usr/share/sip \
+ -c
+ make || die
+}
+
+src_install() {
+ make install || die
+ dodoc ChangeLog LICENSE NEWS README README.Linux README.SunOS THANKS
+ dodir /usr/share/doc/${P}/
+ mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
+ insinto /usr/share/sip
+ doins ${S}/sip/*
+ echo "/${D//\//\\/}/s//\//" > fixpaths.sed
+ sed -i -f fixpaths.sed ${D}usr/lib/python${PYVER}/site-packages/pyqtconfig.py
+}