summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-10-02 12:27:02 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-10-02 12:27:02 +0000
commit855b334e02be5b305771ed1901e858e51a06bb34 (patch)
tree49bd4cc2dc72c72a1638ac2655eeb9ee84dbd344 /dev-python/PyQt4
parentrm old version (diff)
downloadgentoo-2-855b334e02be5b305771ed1901e858e51a06bb34.tar.gz
gentoo-2-855b334e02be5b305771ed1901e858e51a06bb34.tar.bz2
gentoo-2-855b334e02be5b305771ed1901e858e51a06bb34.zip
version bump
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.3.1.ebuild53
-rw-r--r--dev-python/PyQt4/files/digest-PyQt4-4.3.13
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index d5ad944529b8..2a200e39d7af 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.15 2007/08/22 23:58:05 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.16 2007/10/02 12:27:01 caleb Exp $
+
+*PyQt4-4.3.1 (02 Oct 2007)
+
+ 02 Oct 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.1.ebuild:
+ version bump
22 Aug 2007; Robert Buchholz <rbu@gentoo.org> PyQt4-4.3.ebuild:
Added ~ppc (bug #188998)
diff --git a/dev-python/PyQt4/PyQt4-4.3.1.ebuild b/dev-python/PyQt4/PyQt4-4.3.1.ebuild
new file mode 100644
index 000000000000..dc2c9feaf5f6
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.3.1.ebuild,v 1.1 2007/10/02 12:27:01 caleb Exp $
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+ >=dev-python/sip-4.7.1"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+QT4_BUILT_WITH_USE_CHECK="zlib"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" ${S}/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" ${S}/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" ${S}/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.3.1 b/dev-python/PyQt4/files/digest-PyQt4-4.3.1
new file mode 100644
index 000000000000..d7585cbc640d
--- /dev/null
+++ b/dev-python/PyQt4/files/digest-PyQt4-4.3.1
@@ -0,0 +1,3 @@
+MD5 5d0095d7f08a973b4a04e09e7f6ab568 PyQt-x11-gpl-4.3.1.tar.gz 6176590
+RMD160 00424982126f4b76452ae27848a47ce0ef9f7a0c PyQt-x11-gpl-4.3.1.tar.gz 6176590
+SHA256 ed65a89360746a6e07113441a66fbcc545570391ae382fc1004b2f728805d861 PyQt-x11-gpl-4.3.1.tar.gz 6176590