summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-17 09:12:05 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-17 09:12:05 +0000
commitf70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc (patch)
treef8b2f1be4426cbeb95a30223d46b8de3504fc6b0 /dev-python/PyQt
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadgentoo-2-f70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc.tar.gz
gentoo-2-f70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc.tar.bz2
gentoo-2-f70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/PyQt-3.3.2.ebuild24
-rw-r--r--dev-python/PyQt/PyQt-3.4.ebuild26
2 files changed, 21 insertions, 29 deletions
diff --git a/dev-python/PyQt/PyQt-3.3.2.ebuild b/dev-python/PyQt/PyQt-3.3.2.ebuild
index 7263f7d1e45b..8fa208a498c9 100644
--- a/dev-python/PyQt/PyQt-3.3.2.ebuild
+++ b/dev-python/PyQt/PyQt-3.3.2.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.3.2.ebuild,v 1.4 2002/10/17 16:36:53 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.3.2.ebuild,v 1.5 2002/11/17 09:08:21 vapier Exp $
S="${WORKDIR}/PyQt-snapshot-20020722"
DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit( VERSION 3.x ONLY!!)."
SRC_URI="http://www.riverbankcomputing.co.uk/download/snapshots/PyQt/PyQt-snapshot-20020722.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+
SLOT="0"
LICENSE="MIT"
KEYWORDS="x86 sparc sparc64 alpha"
+
DEPEND="virtual/glibc
sys-devel/libtool
>=x11-libs/qt-3.0.4.1
@@ -16,31 +18,25 @@ DEPEND="virtual/glibc
=dev-python/sip-3.3.2"
src_compile() {
-
# Fix for one installation problem. The libtool included with the
# source package does not have the relink patch.
# Use the system libtool instead.
- cd ${S}
- mkdir -p ${D}/usr/lib/python2.2/site-packages
- mkdir -p ${D}/usr/include/python2.2
+ dodir /usr/lib/python2.2/site-packages
+ dodir /usr/include/python2.2
python build.py \
- -d ${D}/usr/lib/python2.2/site-packages \
- -b ${D}/usr/bin \
- -l qt-mt -c
- make
+ -d ${D}/usr/lib/python2.2/site-packages \
+ -b ${D}/usr/bin \
+ -l qt-mt -c
+ make || die
}
src_install() {
-
make DESTDIR=${D} install || die
make DESTDIR=${D} install-eric || die
echo "#!/bin/sh" > ${D}/usr/bin/eric
echo " " >> ${D}/usr/bin/eric
echo "exec python /usr/lib/python2.2/site-packages/eric/eric.py $*" >> ${D}/usr/bin/eric
chmod +x ${D}/usr/bin/eric
- mkdir -p ${D}/usr/share/doc/${P}/
+ dodir /usr/share/doc/${P}/
mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
-
}
-
-
diff --git a/dev-python/PyQt/PyQt-3.4.ebuild b/dev-python/PyQt/PyQt-3.4.ebuild
index 3f62da018615..243fb50ef2c1 100644
--- a/dev-python/PyQt/PyQt-3.4.ebuild
+++ b/dev-python/PyQt/PyQt-3.4.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.4.ebuild,v 1.3 2002/10/17 16:36:53 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.4.ebuild,v 1.4 2002/11/17 09:09:04 vapier Exp $
S="${WORKDIR}/PyQt-x11-gpl-${PV}"
DESCRIPTION="PyQt is a set of Python bindings for the QT 3.x Toolkit"
SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+
SLOT="0"
LICENSE="MIT"
KEYWORDS="x86 ppc sparc sparc64 alpha"
+
DEPEND="virtual/glibc
sys-devel/libtool
>=x11-libs/qt-3.0.4.1
@@ -16,20 +18,17 @@ DEPEND="virtual/glibc
=dev-python/sip-3.4"
src_compile() {
-
- cd ${S}
- mkdir -p ${D}/usr/lib/python2.2/site-packages
- mkdir -p ${D}/usr/include/python2.2
+ dodir /usr/lib/python2.2/site-packages
+ dodir /usr/include/python2.2
python build.py \
- -d ${D}/usr/lib/python2.2/site-packages \
- -e /usr/include/python2.2 \
- -b ${D}/usr/bin \
- -l qt-mt -c
- make
+ -d ${D}/usr/lib/python2.2/site-packages \
+ -e /usr/include/python2.2 \
+ -b ${D}/usr/bin \
+ -l qt-mt -c
+ make || die
}
src_install() {
-
make DESTDIR=${D} install || die
make DESTDIR=${D} install-eric || die
dodoc README.Linux NEWS LICENSE README ChangeLog THANKS
@@ -37,9 +36,6 @@ src_install() {
echo " " >> ${D}/usr/bin/eric
echo "exec python /usr/lib/python2.2/site-packages/eric/eric.py $*" >> ${D}/usr/bin/eric
chmod +x ${D}/usr/bin/eric
- mkdir -p ${D}/usr/share/doc/${P}/
+ dodir /usr/share/doc/${P}/
mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
-
}
-
-