summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-06 17:59:23 +0000
committerTod Neidt <tod@gentoo.org>2002-02-06 17:59:23 +0000
commit5b7be6fb9fd41e8f7274290d7362e00110b5eb15 (patch)
tree319b8c4b9af94f577e65323b39d7b46755a9b742 /dev-python/anygui
parentGNOME fix (diff)
downloadgentoo-2-5b7be6fb9fd41e8f7274290d7362e00110b5eb15.tar.gz
gentoo-2-5b7be6fb9fd41e8f7274290d7362e00110b5eb15.tar.bz2
gentoo-2-5b7be6fb9fd41e8f7274290d7362e00110b5eb15.zip
Updated version, 0.1 released - Yay!
Proposed USE variable wxwin (for wxWindows) included in DEPENDS.
Diffstat (limited to 'dev-python/anygui')
-rw-r--r--dev-python/anygui/ChangeLog9
-rw-r--r--dev-python/anygui/anygui-0.1.ebuild36
-rw-r--r--dev-python/anygui/files/digest-anygui-0.11
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/anygui/ChangeLog b/dev-python/anygui/ChangeLog
index 6285501af67b..2db84e983a03 100644
--- a/dev-python/anygui/ChangeLog
+++ b/dev-python/anygui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/anygui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/anygui/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/anygui/ChangeLog,v 1.2 2002/02/06 17:59:23 tod Exp $
+
+*anygui-0.1 (6 Feb 2002)
+
+ 6 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog :
+
+ Updated version, anygui-0.1 released, Yay! Proposed USE variable
+ wxwin (for wxWindows) used in DEPENDS, *not* Official.
*anygui-0.1_beta1-r1 (1 Feb 2002)
diff --git a/dev-python/anygui/anygui-0.1.ebuild b/dev-python/anygui/anygui-0.1.ebuild
new file mode 100644
index 000000000000..af583f2e0d63
--- /dev/null
+++ b/dev-python/anygui/anygui-0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+#$Header $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Generic GUI Module for Python"
+SRC_URI="http://prdownloads.sourceforge.net/anygui/${P}.tar.gz"
+HOMEPAGE="http://anygui.sourceforge.net/"
+
+DEPEND=">=dev-lang/python-2.0
+ sys-libs/ncurses
+ qt? ( dev-python/PyQt )
+ gtk? ( dev-python/pygtk )
+ tcltk? ( dev-lang/tk-8.3.3 )
+ wxwin? ( dev-python/wxPython )"
+
+# Propsed wxwin use variable for wxGTK for wxWindows? ( dev-python/wxPython ) *NOT* official
+#future:
+# also use variable fltk for fltk? ( dev-python/PyFLTK ) no ebuild for PyFLTK yet
+# java? ( dev-python/jython ) Java Swing (javagui) http://www.jython.org
+
+src_compile() {
+
+ python setup.py build || die "Python Build Failed"
+
+}
+
+src_install() {
+
+ python setup.py install --prefix=${D}/usr || die "Python Install Failed"
+
+ dodoc CHANGELOG.txt INSTALL.txt KNOWN_BUGS.txt LICENSE.txt \
+ MAINTAINERS.txt PKG-INFO README.txt TODO.txt VERSION.txt
+
+}
diff --git a/dev-python/anygui/files/digest-anygui-0.1 b/dev-python/anygui/files/digest-anygui-0.1
new file mode 100644
index 000000000000..9f7c824ccc12
--- /dev/null
+++ b/dev-python/anygui/files/digest-anygui-0.1
@@ -0,0 +1 @@
+MD5 35cee0dbb7895591c9e8b64999715feb anygui-0.1.tar.gz 714724