summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-01-28 18:25:27 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-01-28 18:25:27 +0000
commitadd079590ef95da5ac99840207afa3337cd49bc5 (patch)
treeeef35dadca0e8919ab015120bdfc1cfda54a8b3f /dev-python/autopep8
parentMarked stable for amd64 wrt bug #454048 (diff)
downloadgentoo-2-add079590ef95da5ac99840207afa3337cd49bc5.tar.gz
gentoo-2-add079590ef95da5ac99840207afa3337cd49bc5.tar.bz2
gentoo-2-add079590ef95da5ac99840207afa3337cd49bc5.zip
Port to distutils-r1
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 895192F9)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog8
-rw-r--r--dev-python/autopep8/autopep8-0.8.6-r1.ebuild (renamed from dev-python/autopep8/autopep8-0.8.6.ebuild)23
2 files changed, 14 insertions, 17 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index 3875eb391937..0d05b1492023 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.26 2013/01/28 13:09:28 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.27 2013/01/28 18:25:27 xarthisius Exp $
+
+*autopep8-0.8.6-r1 (28 Jan 2013)
+
+ 28 Jan 2013; Kacper Kowalik <xarthisius@gentoo.org> +autopep8-0.8.6-r1.ebuild,
+ -autopep8-0.8.6.ebuild:
+ Port to distutils-r1
28 Jan 2013; Kacper Kowalik <xarthisius@gentoo.org> -autopep8-0.8.4.ebuild,
-autopep8-0.8.5.ebuild:
diff --git a/dev-python/autopep8/autopep8-0.8.6.ebuild b/dev-python/autopep8/autopep8-0.8.6-r1.ebuild
index 6d47972f77cb..1df3c046d714 100644
--- a/dev-python/autopep8/autopep8-0.8.6.ebuild
+++ b/dev-python/autopep8/autopep8-0.8.6-r1.ebuild
@@ -1,14 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.8.6.ebuild,v 1.1 2013/01/28 10:02:59 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.8.6-r1.ebuild,v 1.1 2013/01/28 18:25:27 xarthisius Exp $
-EAPI=4
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5"
-
-inherit distutils vcs-snapshot
+inherit distutils-r1 vcs-snapshot
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
@@ -20,20 +17,14 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND=">=dev-python/pep8-1.3.2
- dev-python/setuptools"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-PYTHON_MODNAME=${PN}.py
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_${PN}.py
- }
- python_execute_function testing
+python_test() {
+ PYTHONPATH="${BUILD_DIR}"/lib "${PYTHON}" setup.py test || die
}
pkg_postinst() {
- distutils_pkg_postinst
ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
ewarn "(indentation checks inside triple-quotes)."