summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-03-02 09:43:03 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-03-02 09:43:03 +0000
commitafad29f76bad69de46a657f260f395d77ed3c37a (patch)
treeebdcbd7a2d83a72a4a0fa6b36ed4f0d4656459f4 /dev-python/beautifulsoup
parentRemove mask of sci-chemistry/pymol-plugins-cealign as it is removed now (diff)
downloadgentoo-2-afad29f76bad69de46a657f260f395d77ed3c37a.tar.gz
gentoo-2-afad29f76bad69de46a657f260f395d77ed3c37a.tar.bz2
gentoo-2-afad29f76bad69de46a657f260f395d77ed3c37a.zip
Version bump beautifulsoup to 3.2.1.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/ChangeLog7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.2.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index 527a1033bf43..2e85f14992b2 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.58 2012/02/21 07:19:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.59 2012/03/02 09:43:03 djc Exp $
+
+*beautifulsoup-3.2.1 (02 Mar 2012)
+
+ 02 Mar 2012; Dirkjan Ochtman <djc@gentoo.org> +beautifulsoup-3.2.1.ebuild:
+ Version bump to 3.2.1.
21 Feb 2012; Patrick Lauer <patrick@gentoo.org>
beautifulsoup-3.1.0.1-r1.ebuild, beautifulsoup-3.2.0.ebuild:
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.2.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.2.1.ebuild
new file mode 100644
index 000000000000..dc21cb1d19b4
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-3.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.2.1.ebuild,v 1.1 2012/03/02 09:43:03 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="BeautifulSoup"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
+SRC_URI="http://www.crummy.com/software/${MY_PN}/download/3.x/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="python-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!dev-python/beautifulsoup:0"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="BeautifulSoup.py BeautifulSoupTests.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" BeautifulSoupTests.py
+ }
+ python_execute_function testing
+}