summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-04-01 03:05:08 +0000
committerIan Delaney <idella4@gentoo.org>2014-04-01 03:05:08 +0000
commit9a66f3cda1fdb4d9ec77a6fa5156757b43d71120 (patch)
tree1943c0db97eae2649f697501f4ffdf85b6d352b9 /dev-python/biplist
parentAdd a snapshot for python3.4 compat. (diff)
downloadgentoo-2-9a66f3cda1fdb4d9ec77a6fa5156757b43d71120.tar.gz
gentoo-2-9a66f3cda1fdb4d9ec77a6fa5156757b43d71120.tar.bz2
gentoo-2-9a66f3cda1fdb4d9ec77a6fa5156757b43d71120.zip
bump; Add pypy support, tidy deps, update test phase, rm old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/biplist')
-rw-r--r--dev-python/biplist/ChangeLog10
-rw-r--r--dev-python/biplist/biplist-0.6.ebuild (renamed from dev-python/biplist/biplist-0.5-r1.ebuild)22
2 files changed, 21 insertions, 11 deletions
diff --git a/dev-python/biplist/ChangeLog b/dev-python/biplist/ChangeLog
index 3cca6122fced..97953b975cba 100644
--- a/dev-python/biplist/ChangeLog
+++ b/dev-python/biplist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/biplist
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/ChangeLog,v 1.4 2013/05/29 07:02:47 idella4 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/ChangeLog,v 1.5 2014/04/01 03:05:08 idella4 Exp $
+
+*biplist-0.6 (01 Apr 2014)
+
+ 01 Apr 2014; Ian Delaney <idella4@gentoo.org> +biplist-0.6.ebuild,
+ -biplist-0.5-r1.ebuild:
+ bump; Add pypy support, tidy deps, update test phase, rm old
*biplist-0.5-r1 (29 May 2013)
diff --git a/dev-python/biplist/biplist-0.5-r1.ebuild b/dev-python/biplist/biplist-0.6.ebuild
index 13492725f5c9..f1a8457fa3d8 100644
--- a/dev-python/biplist/biplist-0.5-r1.ebuild
+++ b/dev-python/biplist/biplist-0.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/biplist-0.5-r1.ebuild,v 1.1 2013/05/29 07:02:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/biplist/biplist-0.6.ebuild,v 1.1 2014/04/01 03:05:08 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_6,2_7,3_2,3_3} )
-#DISTUTILS_SRC_TEST=nosetests
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 pypy )
+
inherit distutils-r1
DESCRIPTION="A binary plist parser/generator for Python"
@@ -17,12 +17,16 @@ LICENSE="BSD"
SLOT="0"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}] )"
+ dev-python/coverage[${PYTHON_USEDEP}]
+ ${RDEPEND} )"
python_test() {
- # https://github.com/wooster/biplist/issues/5
- nosetests || die "Tests failed under ${EPYTHON}"
+ # https://github.com/wooster/biplist/issues/5; only py3.3
+ if [[ "${EPYTHON}" == 'python3.3' ]]; then
+ nosetests -e testFileRead || die "Tests failed under ${EPYTHON}"
+ else
+ nosetests || die "Tests failed under ${EPYTHON}"
+ fi
}